locked
MACRO PARA ALTERAR COLUNAS DE PROCURA - FÓRMULA PROCV RRS feed

  • Pergunta

  • Pessoal preciso de uma ajuda...

    Gostaria de saber se existe uma macro que quando acionada altera SOMENTE O NÚMERO COLUNA DE UMA FÓRMULA PROCV(valor_procurado; matriz_tabela; num_coluna; procurar_intervalo).

    O motivo é o seguinte: tenho uma planilha de vendas, que tem uma pancada de informações que todo mês devem ser atualizadas através de fórmulas PROCV. Porque muda o mês, altera as metas dos vendedores e etc... eu não queria ficar alterando as colunas do PROCV todo mês, como são muitas fórmulas espalhadas na planilha posso esquecer alguma, dai a informação fica errada, e do mês anterior.

    Lembrando que são várias formulas PROCV, na planilha toda. Como indicar na macro.

    Obrigado.

    terça-feira, 20 de abril de 2010 23:29

Respostas

Todas as Respostas

  • Não creio que seja necessária uma macro para este fim.

    Você pode utilizar uma referência de fórmula.

    Imagine que você quer pesquisar o valor associado a um vendedor, dentro de uma tabela localizada na planilha "DADOSDEVENDA", organizada de forma que na coluna A estão os nomes dos vendedores e nas colunas seguintes estão os valores de janeiro (Coluna B), fevereiro (Coluna C) e assim por diante, ocupando 100 linhas.

    Além disto vamos estabelecer que na célula A1 da planilha "PESQUISA" digitamos o nome do mês a ser pesquisado e na célula A2 o nome do vendedor

    Podemos montar então a seguinte fórmula

    =PROCV(PESQUISA!A2;DADOSDEVENDA!$A$1:$M$100;

    CORRESP(PESQUISA!A1;{"janeiro";"fevereiro";"março";"abril";"maio";

    "junho";"julho";"agosto";"setembro";"outubro";"novembro";"dezembro"};0);FALSO))

    O trecho da fórmula que contém a função CORRESP determina a coluna a ser pesquisada, com base no mês digitado.

     

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta adilsonsoledade quarta-feira, 21 de abril de 2010 01:10
    quarta-feira, 21 de abril de 2010 01:10
  • Boa Tarde Adilson,

    Mais uma vez obrigado pela sua valiosa ajuda.

    Acho que pode funcionar essa sua idéia! Mas você poderia fazer um exemplo numa planilha bem simples para que eu entendesse melhor como funciona esse mecanismo de procura, vai me polpar um grande trabalho de atualização todos os meses.

    Obrigado.

    quarta-feira, 21 de abril de 2010 21:33
  • Boa noie,

    Eis um exemplo que deve auxiliá-lo:

    http://www.4shared.com/document/OAyPkkOE/PesquisaVendedor.html

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta adilsonsoledade quinta-feira, 22 de abril de 2010 01:27
    • Marcado como Resposta diogoska sexta-feira, 23 de abril de 2010 00:42
    quinta-feira, 22 de abril de 2010 01:27
  • Perfeito meu amigo!
    sexta-feira, 23 de abril de 2010 00:42