none
Trigger não reconhece campo novo criado RRS feed

  • Pergunta

  • Boa tarde, pessoal.

    Está acontecendo uma coisa estranha.

    Tenho um banco de dados e inseri alguns campos novos na tabelas. O campo está la e está funcionando com a aplicação.  Consigo inserir dados neles.

    Tenho também uma trigger e por incrível que parece ela não reconhece estes campos novos que criei. Peço para Analisar e não dá erro, porem o campo fica selecionado em vermelho e informa que "Nome de coluna inválido...".

    Alguém sabe como resolver isto?

    Obs: Estou usando o Sql Server 2008 R2

    Obrigada

    Teles


    • Editado Teles quinta-feira, 24 de maio de 2012 17:03
    quinta-feira, 24 de maio de 2012 17:02

Respostas

  • Deleted
    • Sugerido como Resposta Heloisa Pires terça-feira, 5 de junho de 2012 17:31
    • Marcado como Resposta Heloisa Pires sexta-feira, 8 de junho de 2012 14:47
    sábado, 26 de maio de 2012 16:23
  • Teles,

    Estes nomes dos campos em vermelho estão sendo apresentado no Management Studio?

    O que pode estar acontecendo é uma falha na atualização do Cache do IntelliSense, faça um teste utilize a tecla de atalho CTRL+SFHIFT + R para forçar a atualização do cache.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    • Sugerido como Resposta Heloisa Pires terça-feira, 5 de junho de 2012 17:31
    • Marcado como Resposta Heloisa Pires sexta-feira, 8 de junho de 2012 14:47
    segunda-feira, 28 de maio de 2012 17:21

Todas as Respostas

  • Deleted
    • Sugerido como Resposta Heloisa Pires terça-feira, 5 de junho de 2012 17:31
    • Marcado como Resposta Heloisa Pires sexta-feira, 8 de junho de 2012 14:47
    sábado, 26 de maio de 2012 16:23
  • Teles,

    Estes nomes dos campos em vermelho estão sendo apresentado no Management Studio?

    O que pode estar acontecendo é uma falha na atualização do Cache do IntelliSense, faça um teste utilize a tecla de atalho CTRL+SFHIFT + R para forçar a atualização do cache.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    • Sugerido como Resposta Heloisa Pires terça-feira, 5 de junho de 2012 17:31
    • Marcado como Resposta Heloisa Pires sexta-feira, 8 de junho de 2012 14:47
    segunda-feira, 28 de maio de 2012 17:21