locked
Replication trava o servidor RRS feed

  • Pergunta

  • Olá Pessoal,

    Já alguns dias estou tentado replicar o banco de dados, não é muito grande tem 160 tabelas e está com 16Gb de tamanho. Acontece que o assinante fica fora da empresa e faço isto através do alias via TCP. Funcionou bem apenas no primeiro dia. No segundo dia travou o servidor e só depois que eu parei o agent e exclui a replica e que voltou ao normal. Depois disso eu tentei fazer a replica para um outro servidor na mesma rede local, e acontece o mesmo problema, só agora é pior o servidor trava mesmo antes de terminar de configurar o assinante.

    Não sei mais o que fazer, já li um monte de publicaçãoes sobre o assunto, mas todos são muito iguais, mostram o tutorial de como fazer, mas na prática a realidade tem sido outra.

    Grato pela ajuda.

    Daxxel.

     

    • Movido Gustavo Maia Aguiar sexta-feira, 21 de janeiro de 2011 02:14 (De:Gerenciamento, Configuração, Instalação, e Segurança)
    quinta-feira, 20 de janeiro de 2011 23:55

Todas as Respostas

  • Daxxel,

    Como era feita a troca de dados e comunicação entre estes servidores?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sexta-feira, 21 de janeiro de 2011 00:15
    Moderador
  • via TCP/IP.

    Detalhe, o arquivo Log está gigante e a configuração de réplica foi deletada.

     

    sexta-feira, 21 de janeiro de 2011 00:50
  • Daxxel,

    Cara vamos por partes.

    O que esta funcionando neste momento neste servidor?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sábado, 22 de janeiro de 2011 00:20
    Moderador
  • Olá Daxxel,

    Você pode nos fornecer a exata mensagem de erro que você recebe no monitor de publicaçãio quando o problema ocorre?

    Favor responder as perguntas abaixo sobre seu ambiente para que possamos te ajudar a resolver este problema.

    [Environment]
    Operating System:
    Service Pack :
    SQL Version and Edition:
    SQL Service Pack: 
    SQL Build:
    SQL Platform: x86/x64

    Favor colocar informação de todos os servidores envolvidos na replicação.

    Abraços,


    Fábio Oliveira Support Engieer | Microsoft Enterprise and Developer Support
    quinta-feira, 27 de janeiro de 2011 18:56
  • Daxxel,

    Alguma novidade, você verificou o que esta funcionando em seu ambiente?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sábado, 29 de janeiro de 2011 12:57
    Moderador