none
Versoes 655 e 611 - incompatível? RRS feed

  • Pergunta

  • Rapaziada

    Em casa eu uso o ASP.NET, com o SQL Server Express.

    No meu serviço também.

    Mas quando tentei Atachar o banco que eu criei em casa, no meu serviço, ocorreu esse erro:

    O banco de dados 'c:\caminho.....' não pode ser aberto porque sua versão é a 655. Este servidor suporta a versão 611 e anteriores. O caminho de desatualização não é suportado. Não foi possível abrir o novo banco de dados 'c:\caminho.....'. CREATE DATABASE foi anulado. (Microsoft SQL Server, Error: 948)

    Eu sei que o problema é com versões diferentes.

    Como solucionar esse problema, sem ter que desinstalar e reinstalar alguma coisa?

    grato.

    Anderson

    segunda-feira, 7 de junho de 2010 15:16

Respostas

  • Rapaziada,

    Já resolvi o propblema. Em casa eu tinha o SQL Express 2008 e no serviço o 2005. Atualizei o do serviço para o 2008, e funcionou.

    Porém, depois da atualização o projeto nãoqueria atachar o banco que criei em casa, pois havia imcompatibilidade de instancias..

    Então tive que apagar pasta SQLEXPRESS que fica em  \Documents and Settings\<usuario>\Dados de aplicativos\Microsoft\Microsoft SQL Server
    (para Win XP)

    att.

    Anderson

    terça-feira, 8 de junho de 2010 13:05