none
Espaco insuficiente RRS feed

  • Pergunta

  • Boa noite !!!

    Apos referenciar system.data.sqlserverce no meu projeto mobile, esta dando erro de espaço insuficiente ao rodar no emulador pelo VS 2005.

    o que tenho que fazer ??

    Obrigado !!!
    quarta-feira, 27 de maio de 2009 00:56

Respostas

  • Olá,

    Você pode aumentar o tamanho da mémoria do emulador

    Tools>>Options>>Device Tools>> Selecione o emulador que você esta trabalhando >> Properties>>Emulator Options...>> Na aba General>> selecione "Specify RAM size" >> ai você pode informa um valor maior.


    Se a resposta for útil por favor não esqueça de marca.
    Abraços,
    www.danielfonsecacastro.com.br
    Daniel Fonseca Castro
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:41
    quarta-feira, 27 de maio de 2009 12:02
  • Davi,

    Qual a versão do Compact Framework que vc tem instalado no seu pc ?
    Quando o emulador é ativado para rodar sua aplicação, você ja foi em "configurações" => "sistema" => "memória" e conferiu o espaço livre para armazenamento ?
    Já fez isso no instante em que ocorre o erro para verificar se realmente o problema é espaço de armazenamento insuficiente ?

    Já testou fazer o deploy da sua aplicação utilizando outra versão de emulador ?


    Já teste varios projetos de aplicação utilizando NETCF  3.5 , fazendo deploy do mesmo projeto em emuladores 2003 ce, mobile 5 e mobile 6, fazendo conexão a banco sqlce 3.5 ,  capturando dados de WebService e armazenando no banco local do emulador.  Nunca tive um problema de espaço insuficiente...

    Podes postar mais detalhes do problema ?


    Att..

    Miguel Faria

    -------------------------------------------------
    Se a informação for útil, não deixe de marcar.
     
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:42
    sexta-feira, 19 de junho de 2009 21:59
  • Ola, se nao me engando tem uma opçao para vc usar uma pasta do windows para emular um cartao de memoria no emulador... (bem tem no VS2008... nao lembro no vs2005)
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:42
    sábado, 20 de junho de 2009 01:16
    Moderador

Todas as Respostas

  • esse é o erro:
    Error 1 Deployment and/or registration failed with error: 0x8973190e. Error writing file '%csidl_program_files%\deviceapplication5\system.data.dll'. Error 0x80070070: Espaço insuficiente no disco.
       Device Connectivity Component 
    quarta-feira, 27 de maio de 2009 00:57
  • Olá,

    Você pode aumentar o tamanho da mémoria do emulador

    Tools>>Options>>Device Tools>> Selecione o emulador que você esta trabalhando >> Properties>>Emulator Options...>> Na aba General>> selecione "Specify RAM size" >> ai você pode informa um valor maior.


    Se a resposta for útil por favor não esqueça de marca.
    Abraços,
    www.danielfonsecacastro.com.br
    Daniel Fonseca Castro
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:41
    quarta-feira, 27 de maio de 2009 12:02
  • Daniel, obrigado !!!

    Ja fiz de tudo, aumentei a memoria para 256 que é o maximo que ele permite, mas nao adianta. Outra coisa que percebi é que eu vou na propria IDE e faço as alteracoes com o emulador fechado, mas quando inicia o emulador vou nas configuracoes do dispositivo e continha 128 e nao deixa eu alterar. Eu acho que nao é problema de memoria, e sim de disco, mas nao encontrei nenhum lugar onde eu posso configurar um disco maior ou até mesmo configurar um memory card.

    Por favor me ajudem nisso, pq tenho que entregar um trabalho e estou com pouco tempo.

    Obrigado !!!
    quarta-feira, 27 de maio de 2009 12:09
  • Acontece o seguinte

    Estou usando o VS 2005. Entao eu instalei o SQL Server 2005 Mobile Edtion e o SQL Server Compact Edition. Quando eu referencio o System.Data.SqlServerCE no meu projeto da uns erros. Diz que eu tenho que atualizar a versao do System, e do System.Data. O que eu fiz: Exclui a referencia que existia do System e do System.Data, e cliquei no opcao que o proprio VS fornece para solucionar o problema, entao ele mesmo adiciona as novas versoes das dll´s em questao. A partir disso nao roda mais no emulador, dando o erro de espaço insuficiente.

    Obrigado !!!
    quarta-feira, 27 de maio de 2009 12:31
  • Davi,

    Qual a versão do Compact Framework que vc tem instalado no seu pc ?
    Quando o emulador é ativado para rodar sua aplicação, você ja foi em "configurações" => "sistema" => "memória" e conferiu o espaço livre para armazenamento ?
    Já fez isso no instante em que ocorre o erro para verificar se realmente o problema é espaço de armazenamento insuficiente ?

    Já testou fazer o deploy da sua aplicação utilizando outra versão de emulador ?


    Já teste varios projetos de aplicação utilizando NETCF  3.5 , fazendo deploy do mesmo projeto em emuladores 2003 ce, mobile 5 e mobile 6, fazendo conexão a banco sqlce 3.5 ,  capturando dados de WebService e armazenando no banco local do emulador.  Nunca tive um problema de espaço insuficiente...

    Podes postar mais detalhes do problema ?


    Att..

    Miguel Faria

    -------------------------------------------------
    Se a informação for útil, não deixe de marcar.
     
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:42
    sexta-feira, 19 de junho de 2009 21:59
  • Ola, se nao me engando tem uma opçao para vc usar uma pasta do windows para emular um cartao de memoria no emulador... (bem tem no VS2008... nao lembro no vs2005)
    • Marcado como Resposta DaviSaba sábado, 20 de junho de 2009 14:42
    sábado, 20 de junho de 2009 01:16
    Moderador
  • Obrigado a todos !!!

    Mas eu estou usando o VS2008 e agora todos esses problemas nao estao acontecendo mais. A solucao que desenvolvemos utiliza WebService, mas quando atualizamos os dados no dispositivo, preciso ter um banco local. Tentei usar XML antes, mas fica muito lento. Com SQL CE ficou legal a solucao, e com o VS2008 esta tudo indo muito bem.

    Acredito que ao terminar essa solucao, vou poder colaborar com o forum respondendo algumas duvidas basicas do pessoal.

    Obrigado !!!
    sábado, 20 de junho de 2009 14:41