none
Erro de Memória no Emulador RRS feed

  • Pergunta

  • Bom dia companheiros...

    Estou com um problema... Os erros apresentados são os seguintes...

    Erro no Emulador:
    Storage Memory
    Storage memory is critically low. If you do not increase not be able to start some programs Use File Explorer to delete files you no longer need or move files to a storage card.

    Erro no VS2005:
    Error 1 Deployment and/or registration failed with error: 0x8973190e. Error writing file '%csidl_program_files%\dapserviceorder\system.deployment.dll'. Error 0x80070070: There is not enough space on the disk.
       Device Connectivity Component 

    Esse erro acontece no momento de deploying.

    Estrutura:
    -SO (emulador): Windows Mobile 5
    -Banco: SQL Server Mobile 2005
    -VS 2005
    -Criei o banco, o dataset tipado e uma classe que implementa as ações no dataset.
    -Tenho um form "splash", uma form "main" e outro de cadastro.
    -A solução contem dois projetoso, um projeto com o dataset tipado e a classe e outro projeto do tipo Windows Mobile 5. Fiz uma referência no projeto "device application" para o projeto do dataset + classe.

    Até eu adicionar essa referência tudo funcionava que era uma maravilha.

    [ ]'s

    sexta-feira, 16 de março de 2007 12:02

Respostas

  • Gustavo,

    Você pode aumentar a memória do emulador em Star/Settings/System/Memory. Lá você muda o tamanho do File Storage.

    []s,
    Carlos.

    domingo, 18 de março de 2007 21:57
  • Carlos,

    Essa opção não está disponível no emulador. Já tinha olhado ela, mas não houve jeito.

    Não que eu resolvi... mas eu mudei um pouco o jeito de trabalhar e por enquanto estou levando o projeto.

    Valeu pela lembrança.

    [ ]'s

    terça-feira, 20 de março de 2007 10:54
  • Voce pode configurar pela própria IDE, procure o ícone "Device Options" ele geralmente fica do lado do icone "Connect to Device".

    OU

     vá no menu "Tools", e depois clique em "Options", procure e expande a opção na lista esquerda "Device Tools", e clique em "Devices"

    E

    Selecione o emulador que voce deseja trabalhar, clique no botão "Properties", na janela que abrir clique no botão "Emulator Options" e na janela que abrir voce terá as opções para aumentar o tamanho das memórias do emulador selecionado e que a propria IDE inicializa.

     

    Abraços

    • Sugerido como Resposta Ruddy Paz quinta-feira, 13 de janeiro de 2011 14:10
    • Marcado como Resposta AndreAlvesLimaModerator quinta-feira, 24 de fevereiro de 2011 22:53
    quinta-feira, 4 de outubro de 2007 21:21

Todas as Respostas

  • Gustavo,

    Você pode aumentar a memória do emulador em Star/Settings/System/Memory. Lá você muda o tamanho do File Storage.

    []s,
    Carlos.

    domingo, 18 de março de 2007 21:57
  • Carlos,

    Essa opção não está disponível no emulador. Já tinha olhado ela, mas não houve jeito.

    Não que eu resolvi... mas eu mudei um pouco o jeito de trabalhar e por enquanto estou levando o projeto.

    Valeu pela lembrança.

    [ ]'s

    terça-feira, 20 de março de 2007 10:54
  • Pessoal,

    me ocorreu o mesmo problema descrito pelo Gustavo. Por acaso alguém sabe se existe a possibilidade de aumentar a memória do emulador?


    At. Rodrigo
    quinta-feira, 4 de outubro de 2007 17:37
  • Voce pode configurar pela própria IDE, procure o ícone "Device Options" ele geralmente fica do lado do icone "Connect to Device".

    OU

     vá no menu "Tools", e depois clique em "Options", procure e expande a opção na lista esquerda "Device Tools", e clique em "Devices"

    E

    Selecione o emulador que voce deseja trabalhar, clique no botão "Properties", na janela que abrir clique no botão "Emulator Options" e na janela que abrir voce terá as opções para aumentar o tamanho das memórias do emulador selecionado e que a propria IDE inicializa.

     

    Abraços

    • Sugerido como Resposta Ruddy Paz quinta-feira, 13 de janeiro de 2011 14:10
    • Marcado como Resposta AndreAlvesLimaModerator quinta-feira, 24 de fevereiro de 2011 22:53
    quinta-feira, 4 de outubro de 2007 21:21