none
[Resolvido] Visual Studio 2008 + C# + SQLite = Problemas... RRS feed

  • Pergunta

  • Pessoal estou utilizando o Visual Studio 2008 com C#... Para banco de dados gostaria de utilizar o Sqlite, e estou tendo este problemas ao depurar na VM do Mindows Mobile 5:

    Can't find PInvoke DLL 'SQLite.Interop.DLL'.

    Alguma dica?

     

    Aproveitando, alguém tem algum site ou tutorial que ensine a criar um banco de dados em tempo de execução, pode ser com qualquer outro SGBD... que me dizem?

    Em um projeto do Android, eu leio arquivos .txt com os creates tables ncessários, caso o banco não exista... seria muito bom se pudesse ser assim também neste projeto... tem como?!

    segunda-feira, 21 de junho de 2010 14:20

Respostas

  • Ela o seguite erro:

    Ao colocar a DLL como REFERENCIA do projeto, o atributo "Copy local" estava como FALSE, apenas mudei para TRUE, e o próprio degugger joga as dll´s para Virtual Device, ou seja... ao compilar e etc ele não estava levando junto as DLL que eram  Referencias do projeto.

     

    Abraços

    sexta-feira, 25 de junho de 2010 11:11

Todas as Respostas

  • Ola

    Bom o erro a que vc mostra só pode ser porque vc não tem essa DLL, te dou uma dica vc pode usar o SQLCE tenho varias aplicações usando o SQL e olha fica show é logico para determinadas aplicações uso SQL para outras uso um Banco Oracle este ja tem acesso externo acesso direto de um servidor de uma base de produção que temos ... mas te dou um conselho uso o SQLCE

    Quanto a criação do Banco de Dados segue abaixo um link que deve te ajudar ele mostra a conexão com o Banco de Dados ele testa se o BAnco de Dados existe e no final da pagina tem um exemplo que criação do Banco de Dados o exemplo esta em VB.Net mas vc pode altera-lo com facilidade para C#

    http://www.linhadecodigo.com.br/ArtigoImpressao.aspx?id=57

    Qualquer coisa avisa que agora aqui não tenho o arquivo mas no meu trabalho se não me engano tenho um script para a criação do Banco de Dados ... mas creio que com esse link acima vc ja consegue

    Abs.


    Junior
    sexta-feira, 25 de junho de 2010 00:30
  • Ela o seguite erro:

    Ao colocar a DLL como REFERENCIA do projeto, o atributo "Copy local" estava como FALSE, apenas mudei para TRUE, e o próprio degugger joga as dll´s para Virtual Device, ou seja... ao compilar e etc ele não estava levando junto as DLL que eram  Referencias do projeto.

     

    Abraços

    sexta-feira, 25 de junho de 2010 11:11
  • Ela o seguite erro:

    Ao colocar a DLL como REFERENCIA do projeto, o atributo "Copy local" estava como FALSE, apenas mudei para TRUE, e o próprio degugger joga as dll´s para Virtual Device, ou seja... ao compilar e etc ele não estava levando junto as DLL que eram  Referencias do projeto.

     

    Abraços

    Dante, esta acontecendo o mesmo com minha aplicação. Já alterei o "Copy Local" para True e não resolveu.

    Será que você pode me ajudar com mais algumas dicas?


    Elcio João de Lima - VB6, C#, Plataforma .NET e WM [Se o post foi útil, não esqueça de marcá-lo. Obrigado]
    segunda-feira, 19 de julho de 2010 17:49