none
Erro ao instalar o Visual Studio 2013 no Windows 7 SP1 64 Bits RRS feed

  • Pergunta

  • Olá a todos.

    Estou tentando instalar o Visual Studio 2013 Professional no Windows 7 SP1 64 Bits.

    Porém na instalação surge o seguinte erro:

    Alguém sabe como contornar este problema?

    Obrigado.

    sábado, 2 de novembro de 2013 13:52

Respostas

  • Caríssimos,

    Saudações!

    Bem, fiz o seguinte: formatei, e fiz todas as atualizações, bem como instalar como o .NET 4.5.1.

    Após isso, consegui instalar sem problemas o Visual Studio 2013.

    Espero ter contribuído.

    Cordial abraço,

    Adelito Farias 

    • Marcado como Resposta Giovani Cr quinta-feira, 21 de novembro de 2013 19:08
    domingo, 17 de novembro de 2013 18:35
  • Instala primeiro o NET FRAMEWORK 3.5 ai acredito que vai conseguir instalar.
    • Marcado como Resposta Giovani Cr quinta-feira, 21 de novembro de 2013 19:08
    terça-feira, 19 de novembro de 2013 19:43
  • Não consigo instalar nem o Visual e nem o .Net. As imagens com os erros em ambas as instalações podem ser vistas lá em cima, no início deste forum.

    Tenho o Internet Explorer 10 instalado sim.

    Obrigado

    Welinton

    Outra coisa, meu Windows esta totalmente atualizado, não tem nenhuma atualização pendente.

    Obrigado

    Welinton

    • Marcado como Resposta Welinton Munhoz terça-feira, 26 de novembro de 2013 15:59
    terça-feira, 26 de novembro de 2013 15:59

Todas as Respostas

  • Boa noite Wellinton,

    A imagem é explícita, você cancelou a instalação da ferramenta Windows Development Kit e, você não tem o último Framework necessário para a IDE, que é a versão 4.5.1. Mas, o Visual Studio traz consigo o .NET Framework atualizado.

    Você pode desinstalar e instalar novamente e, claro aguardar o instalação completa. Antes, baixa o .NET 4.5.1 no site da Microsoft.

    Espero ter ajudado,

    Victor Oliveira.

    sábado, 2 de novembro de 2013 23:54
  • Eu não cancelo a instalação, aparece esta mensagem durante a instalação e como podemos ver só tem a opção close.

    Baixei o .NET 4.5.1, mas também da erro na instalação, conforme imagem abaixo:

    Não consigo de maneira nenhuma instalar o .net 4.5.1 e nem o Visual 2013.

    Já tenho o visual 2010 e o 2012 instalado e funcionam perfeitamente. Vou começar a desenvolver um novo aplicativo e gostaria de já iniciar no Visual 2013.

    Obrigado

    domingo, 3 de novembro de 2013 01:10
  • Outra coisa que reparei, o erro na instalação do Visual Studio 2013 se dá justamente quando esta instalando o .net 4.5.1.

    Então meu PC tem alguma restrição quanto a instalação do .net 4.5.1, só não sei o que é.

    O duro que baixei tudo no MSDN, ou seja, alguma coisa esta errada com estes instaladores. Como pode lançarem algo que não funciona?

    Vi que o Windows 8.1 já vem com o .net 4.5.1, porém, não quero mudar meu sistema operacional. O Windows 8 e também o 8.1 são muito improdutivos.

    Desde já agradeço a todos.

    domingo, 3 de novembro de 2013 01:19
  • Boa tarde,

    Eu creio que não seja problema do instalador, pois eu instalei normalmente aqui no meu windows 7 SP1 64

    Você tentou fazer o download do .NET Framework desse link? http://www.microsoft.com/en-ph/download/details.aspx?id=40772

    E o download do VS 2013 foi feito desse link? http://www.microsoft.com/visualstudio/ptb/downloads#d-professional

    Tente fazer o seguinte: Navegue até o editor de registros (windows +r, digite regedit e de ok).

    No editor de registros vá até as seguintes chaves: 

    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted

    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

    Veja se na coluna nome você tem .NET Framework 4.5.1 ou .NET Framework 4.5 e delete essas entradas.

    Rode novamente o instalador do .NET Framework 4.5.1

    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 4 de novembro de 2013 18:12
  • Olá Giovani, baixei os instaladores direto dos Downloads para Assinantes do MSDN:

    https://msdn.microsoft.com/pt-br/subscriptions/securedownloads/hh442898

    Baixei o .NET Framework 4.5.1 do link que você indicou, porém, o erro persiste.

    No registro do Windows não há as informações que você indicou, conforme imagem abaixo:

    Vale lembrar que já tenho o Visual 2010 e o 2012 instalados, portanto, tenho o .net 4.0, e 4.5 instalados. Só o 4.5.1 que não instala de maneira alguma.

    Obrigado, Welinton

    terça-feira, 5 de novembro de 2013 00:45
  • Boa tarde,

    Deixe-me fazer uma pergunta: Você esta com o Internet Explorer 10 no seu Windows?

    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 11 de novembro de 2013 17:19
  • Boa tarde Welinton,

    Você encontrou uma solução para seu problema?

    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 13 de novembro de 2013 14:34
  • Caríssimos,

    Saudações!

    Bem, fiz o seguinte: formatei, e fiz todas as atualizações, bem como instalar como o .NET 4.5.1.

    Após isso, consegui instalar sem problemas o Visual Studio 2013.

    Espero ter contribuído.

    Cordial abraço,

    Adelito Farias 

    • Marcado como Resposta Giovani Cr quinta-feira, 21 de novembro de 2013 19:08
    domingo, 17 de novembro de 2013 18:35
  • Instala primeiro o NET FRAMEWORK 3.5 ai acredito que vai conseguir instalar.
    • Marcado como Resposta Giovani Cr quinta-feira, 21 de novembro de 2013 19:08
    terça-feira, 19 de novembro de 2013 19:43
  • Não consigo instalar nem o Visual e nem o .Net. As imagens com os erros em ambas as instalações podem ser vistas lá em cima, no início deste forum.

    Tenho o Internet Explorer 10 instalado sim.

    Obrigado

    Welinton

    terça-feira, 26 de novembro de 2013 15:58
  • Não consigo instalar nem o Visual e nem o .Net. As imagens com os erros em ambas as instalações podem ser vistas lá em cima, no início deste forum.

    Tenho o Internet Explorer 10 instalado sim.

    Obrigado

    Welinton

    Outra coisa, meu Windows esta totalmente atualizado, não tem nenhuma atualização pendente.

    Obrigado

    Welinton

    • Marcado como Resposta Welinton Munhoz terça-feira, 26 de novembro de 2013 15:59
    terça-feira, 26 de novembro de 2013 15:59
  • Boa tarde Caros,

    Estou com o mesmo problema. Alguém já conseguiu detectá-lo?

    Grato

    Genê.


    • Editado Genê domingo, 16 de fevereiro de 2014 17:16
    domingo, 16 de fevereiro de 2014 17:13
  • Tenho o net 4.5.1 instalado mas mesmo assim o visual studio não instala :/
    sexta-feira, 22 de agosto de 2014 20:16
  • verifica tbm a versão do seu Windows se eh 32 ou 64

    vc pode esta baixando a versão do NET Framework

    da versão errada.

    sábado, 4 de junho de 2016 04:21