none
Erro na migração para Visual Studio Team System RRS feed

  • Pergunta

  • Olá pessoal,

    Eu usava o VS 2008 Code Name "Orcas" Beta1 agora mudei para o Visual Team System.
    Na migração deu um problema com o System.Data.DataSetExtensions, pois tinha duas referências as versões 2.0.0 e 3.5.0 Seguindo umas dicas removi a 2.0.0 e na minha máquina funcionou tudo certo.
    Acontece que na máquina do cliente estava rodando a versão feita no "Orcas". Agora fui atualizar a aplicação(com uma versão feita no VSTS) e deu um problema também referente System.Data.DataSetExtensions. No cliente removi e reinstalei a .net3.5, no entanto persiste o erro.

    Eis o erro:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.InvalidOperationException: Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
    The request failed with the error message:
    --
    <html>
        <head>
            <title>Configuration Error</title>
            <style>
             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
             pre {font-family:"Lucida Console";font-size: .9em}
             .marker {font-weight: bold; color: black;text-decoration: none;}
             .version {color: gray;}
             .error {margin-bottom: 10px;}
             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
            </style>
        </head>

        <body bgcolor="white">

                <span><H1>Server Error in '/Saber.Web.WS' Application.<hr width=100% size=1 color=silver></H1>

                <h2> <i>Configuration Error</i> </h2></span>

                <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

                <b> Description: </b>An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
                <br><br>

                <b> Parser Error Message: </b>Could not load file or assembly 'System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. O sistema não pode encontrar o arquivo especificado.<br><br>

                <b>Source Error:</b> <br><br>

                <table width=100% bgcolor="#ffffcc">
                   <tr>
                      <td>
                          <code><pre>

    Line 34:                 <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    Line 35:                 <add assembly="System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    <font color=red>Line 36:                 <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>
    </font>Line 37:         <!--
    Line 38:             The <authentication> section enables configuration </pre></code>

                      </td>
                   </tr>
                </table>

                <br>

                <b> Source File: </b> C:\Saber\Saber.Web.WS\web.config<b>    Line: </b> 36
                <br><br>

                <b>Assembly Load Trace:</b> The following information can be helpful to determine why the assembly 'System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' could not be loaded.<br><br>

                <table width=100% bgcolor="#ffffcc">
                   <tr>
                      <td>
                          <code><pre>

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    </pre></code>

                      </td>
                   </tr>
                </table>

                <br>

                <hr width=100% size=1 color=silver>

                <b>Version Information:</b> Microsoft .NET Framework Version:2.0.50727.1378; ASP.NET Version:2.0.50727.1378

                </font>

        </body>
    </html>
    <!--


    Já viram algo assim ? Fico na espera de ajuda. Obrigado pessoal
    sábado, 29 de março de 2008 19:13