locked
Banco de Dados - Extrair maior valor RRS feed

  • Pergunta

  • Olá, tenho a seguinte situação:

     

    Ocorrências Título
    2 a
    4 b
    14 c
    6 d
    2 e
    14 f
    6 g
    10 h
    8 i
    8 j
    0 k
    8 l
    14 m

     

    Gostaria de saber se existe uma maneira automática para que o Excel me informe quais são os títulos correspondentes ao critério "=maior()".

     

    Por exemplo, quero saber, automaticamente, qual o titulo com maior ocorrências, bem como o segundo, o terceiro, etc.

     

    Agradeço desde já a ajuda!

    quinta-feira, 23 de agosto de 2007 13:59

Respostas

  • Oi Lionnz, faça assim

    =PROCV(MAIOR(A1:A13;1);A1:B13;2;0)

    e para não arepsentar erro nenhum, assim

    =SE(É.NÃO.DISP(PROCV(MAIOR(A1:A13;1);A1:B13;2;0));"";PROCV(MAIOR(A1:A13;1);A1:B13;2;0))

     

    SÓ MUDE AS CÉLULAS CONFORME SUA NECESSIDADE

    SE ISTO LHE AJUDAR POR FAVOR MARQUE COMO RESPONDIDA

    ABRAÇOS.

     

    sexta-feira, 24 de agosto de 2007 20:13

Todas as Respostas

  • Oi Lionnz, faça assim

    =PROCV(MAIOR(A1:A13;1);A1:B13;2;0)

    e para não arepsentar erro nenhum, assim

    =SE(É.NÃO.DISP(PROCV(MAIOR(A1:A13;1);A1:B13;2;0));"";PROCV(MAIOR(A1:A13;1);A1:B13;2;0))

     

    SÓ MUDE AS CÉLULAS CONFORME SUA NECESSIDADE

    SE ISTO LHE AJUDAR POR FAVOR MARQUE COMO RESPONDIDA

    ABRAÇOS.

     

    sexta-feira, 24 de agosto de 2007 20:13
  • Lionzz,

     

    a resposta do LEANDRO está correta...

    você pode atingir o mesmo resultado aninhando as funções ÍNDICE, CORRESP e MAIOR...

    no caso da função ÍNDICE, é possível vc obter 'resultados mais robustos' no que diz respeito à uma situação que tenha mais de duas colunas, o que não acontece no seu exemplo proposto...

     

    =ÍNDICE(A1:B10;CORRESP(MAIOR(A1:A10;1);A1:A10;FALSO);2)

     

    Caso não tenha entendido a fórmula, retorne a dúvida!
    Abraço!

    quarta-feira, 5 de setembro de 2007 04:10
  • Lionz, por favor, qunado puder marque como respondida se te atender.

    abraço

    quarta-feira, 12 de setembro de 2007 15:26