none
ReportViewer x Paramêtros RRS feed

  • Pergunta

  • Olá comunidade !

    Fiz um relatório simples na minha máquina mesmo, com um parametro combobox, coloquei no servidor de Relatórios, até ai tudo bem....funcionando certinho.....

    Abri um novo projeto , coloquei um ReportViewer

    e configurei assim

    ReportViewer1.ServerReport.ReportServerUrl = new System.Uri("http://localhost/reportServer$Sql2005");

    ReportViewer1.ServerReport.ReportPath = "/Relatorios/rptVendas";

    O projeto roda abre o relatorio , tudo ok !!!

    Mas qdo seleciono uma outra opção do combobox ele dá um postback e retorna com a primeira opção

    Alguém já viu problema parecido ? Não tenho certeza se é configuração no ReportViewer ou algum bug porque se eu chamar direto pelo servidor de relatorio o parametro funciona perfeitamente

    Valmir [ ]s.

     

     

     

    quinta-feira, 24 de agosto de 2006 21:40

Todas as Respostas

  • Valmir,

    Tudo joia?

    O que acontece é que ele dá Refresh na tela, porem não dá refresh no relatório.

    Basta implementar esse comando no PostBack do Combobox.

    ReportViewer1.LocalReport.Refresh();

    Thiago Cruz
    thiago.cruz@dotnetraptors.com.br
    Blog: http://mgtcbs.spaces.live.com

    terça-feira, 29 de agosto de 2006 05:37
  • Oi Thiago, tudo bem. Obrigado por responder.

    Desculpe mas não entendi. Eu não acho onde colocar o comando, o parametro está dentro do relatorio.....

    Eu não tenho uma tela onde escolho algumas opções  e depois passo essas opções como paramêtros ,

    Não sei se vc me entendeu.....

    Vou passar o arquivo p/ seu email p/ vc ver.....

    Muito Obrigado.

     

    []s

     

    terça-feira, 29 de agosto de 2006 14:42