none
Problemas ao executar aplicação... RRS feed

  • Pergunta

  • Pessoal.
    Olha só que estranho.
    Após eu instalar uns activeX aqui em minha máquina, o VS2008 começou a dar o seguinte erro:
    "Unabled to launch the ASP.NET Development Server".

    Tudo isso ocorre quando tento executar uma aplicação Asp.Net. 
    Até 2 dias atrás estava tudo certo.
    Alguém tem alguma sugestão???
    Grato.



    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quarta-feira, 4 de novembro de 2009 16:21

Respostas

  • Valeu Kaue...

    Esse erro para mim tbm é inédito.
    Felizmente consegui contornar...
    Configurei nas propriedades do projeto para executar e debugar através do IIS. Nem sabia que era possível.
    Mas gostaria de poder debugar novamente no servidor temporário do VS2008.
    Se alguém souber como, por favor me informe.

    Grato.





    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    • Sugerido como Resposta Harley Araujo sexta-feira, 6 de novembro de 2009 12:19
    • Marcado como Resposta Glauber Rocha quinta-feira, 12 de novembro de 2009 11:28
    quarta-feira, 4 de novembro de 2009 16:33

Todas as Respostas

  • Vixii.

    Sugestão eu até tenho:
    http://forums.asp.net/t/1437368.aspx 

    http://forums.asp.net/t/1303467.aspx 

    http://forums.asp.net/t/1209387.aspx 


    Desculpe a falta de informação. Esses links eu consegui pesquisando na Net alguns casos parecidos que algumas idéias resolveram.
    Nunca me deparei com esse erro.
    Caso outro usuário aí do fórum saiba a resposta mais precisa ficamos no aguardo.
    quarta-feira, 4 de novembro de 2009 16:29
  • Fale,

    Olha esse link bem interessante:

    http://selectall.wordpress.com/2009/07/01/unable-to-launch-asp-net-development-server/

    http://forums.asp.net/t/1303467.aspx

    Abraço!


    Se a resposta solucionar sua dúvida, favor - Votar como Útil Abraço!
    quarta-feira, 4 de novembro de 2009 16:32
  • Valeu Kaue...

    Esse erro para mim tbm é inédito.
    Felizmente consegui contornar...
    Configurei nas propriedades do projeto para executar e debugar através do IIS. Nem sabia que era possível.
    Mas gostaria de poder debugar novamente no servidor temporário do VS2008.
    Se alguém souber como, por favor me informe.

    Grato.





    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    • Sugerido como Resposta Harley Araujo sexta-feira, 6 de novembro de 2009 12:19
    • Marcado como Resposta Glauber Rocha quinta-feira, 12 de novembro de 2009 11:28
    quarta-feira, 4 de novembro de 2009 16:33
  • Da uma olhada de como está o debug da sua aplicação nas propriedades dela.
    quarta-feira, 4 de novembro de 2009 16:34
    Moderador
  • Então Glauber.

    Esse link http://forums.asp.net/t/1437368.aspx fala sobre uma configuração que você poderia tentar.

    O 3º e 4º comentários desse link. Tente com eles.
    quarta-feira, 4 de novembro de 2009 16:38
  • Aparentemente está tudo OK nas propriedades da aplicação (se bem que não manjo muito desta configuração).
    Tentei trocar a porta do "Launch Server" mas também não surtiu efeito algum....


    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quarta-feira, 4 de novembro de 2009 16:41
  • Kaue.
    Abri o tal do arquivo host apontado neste link e estava tudo certinho.

    127.0.0.1       localhost



    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quarta-feira, 4 de novembro de 2009 16:50
  • Fale,

    O Caminho que o  Kaue fala é esse:

    C:\WINDOWS\system32\drivers\etc\ hosts

    Abraço!


    Se a resposta solucionar sua dúvida, favor - Votar como Útil Abraço!
    quarta-feira, 4 de novembro de 2009 16:56
  • Então.
    Dentro deste arquivo tinha configurado apenas:
    127.0.0.1       localhost

    Não era assim que devia estar???



    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quarta-feira, 4 de novembro de 2009 17:01
  • Fale,

    Dá um Restart o IIS

    Abraço!
    Se a resposta solucionar sua dúvida, favor - Votar como Útil Abraço!
    quarta-feira, 4 de novembro de 2009 17:09
  • Opa e nas propriedades da solution :), depois em configuration properties.
    quarta-feira, 4 de novembro de 2009 17:09
    Moderador
  • Isso mesmo. Se estivesse diferente disso é que tinha que alterar(de acordo com o link daquela fórum).

    No seu caso que já estava "certo" pode desconsiderar esse link.
    quarta-feira, 4 de novembro de 2009 17:10
  • Nas propriedades da Solution em Configuration Properties está tudo marcado como DEBUG... Alguém poderia me informar qual a porta usada pelo Visual Studio Development Server de vocês??? Aqui está marcado como Specific Port 3002


    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quarta-feira, 4 de novembro de 2009 17:46
  • Glauber,

    Você conseguiu solucionar o seu problema?
    Caso afirmativo poste a solução para que outras pessoas se beneficiem.

    Att,
    Fernanda


    “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    quarta-feira, 11 de novembro de 2009 16:00
    Moderador
  • Glauber,  você pode configuar a porta do Visual Studio Development Server para ser reservada dinamicamente. Não gosto muito desta opção, normalmente escolho portas especificas para cada projeto, para evitar criar duas instancia do Visual Studio Development Server.
    Sobre o número da porta, você pode colocar qual você quiser, desde que não esteja em uso (para descobrir, use um portscan ou tente no chute mesmo. Normalmente coloco 2222,3333 e assim por diante).
    Rubens Arandas
    quarta-feira, 11 de novembro de 2009 22:57
  • Fernanda.
    A solução que encontrei foi fazer o build das aplicações pelo IIS.
    Não é o ideal, mas pelo menos não para a produção.
    Grato a todos.



    Notepad na mão e uma idéia na cabeça......Se foi útil, marca lá.... Me ajuda que eu marco também... heheheh
    quinta-feira, 12 de novembro de 2009 11:28