locked
Função IF RRS feed

  • Pergunta

  • Olá a todos,

    Estou a fazer um mapa (horário)  no excel e necessito de saber como posso fazer o seguinte:

    uma célula com hora de entrada e outra com célula de saída e outra célula com a subtracção das duas células que é o resultado das horas trabalhadas.

    Na célula das horas trabalhadas preciso que sempre que o horário exceda as 7 horas que seja subtraído uma hora e sempre que o resultado seja de 5 horas o valor se mantenha...

    Obrigado


    RS
    sexta-feira, 24 de setembro de 2010 23:00

Todas as Respostas

  • Olá,

    Primeiro que tudo, a parte das 5 horas não entendi!

    De resto, assumindo que tens na coluna A o valor da Hora Entrada e na coluna B o valor da Hora Saída, do género:

    Hora Entrada   Hora Saída

       7:00               15:30

    Na coluna C colocas a formula:

    =IF(B2-A2>7/24,(B2-A2)-1/24,B2-A2) ou em português:

    =SE(B2-A2>7/24,(B2-A2)-1/24,B2-A2)

    Passo a explicar a fórmula: verifico se a diferença entre Hora Saída-Hora Entrada é superior a 7 horas. Para isso divido as 7 horas pelas 24 horas do dia visto que os valores das horas estão no formato Hora. Assim, na prática o que estou a verificar é se a diferença entre a Hora Saída e Hora Entrada é superior a 0.291667. Se for acho a diferença e retiro 1 horas a dividir pelas 24 horas do dia, isto é, neste caso 7:00 às 15h30 o valor numérico que é achado é 0.35. Neste caso é superior a 0.291667 (7 horas) pelo que retiro 0.041667 que é o que corresponde a uma hora. Estes valores consegues ver se alterares a formatação das células de Tempo para Numérico. Caso o valor da diferença não seja superior a 7 horas, coloco o valor da diferença na célula.

    Espero que a resposta não tenha sido muito confusa.

    Abraço,

    jppinto

    www.excel-user.blogspot.com

    sábado, 25 de setembro de 2010 21:47