none
visual studio não funciona step over " debug " RRS feed

  • Pergunta

  • Bom dia amigos, de uns dias para cá o Debug não funciona mais, insero o BreakPoint no código e ao dar step over ele passa direto, parece ser uma falha do Visual Studio 2013, pois andei pesquisando e nada resolvel. Ja mexi nas opções e nada.

    Por favor alguém pode me ajudar!


    Anderson.mds

    quinta-feira, 12 de março de 2015 14:53

Respostas

Todas as Respostas

  • Opa blz Anderson, me tira uma dúvida, você marca por exemplo a linha 15 com um breakpoint e quando esta na 14 você aperta F10 para dar uma "Step Over", o que acontece? Ou você deseja entrar no método da linha 15 dando um "Step Into"?

    Rodrigo Reis Ferreira
    Microsoft Certified

    quinta-feira, 12 de março de 2015 16:43
  • Boa tarde Anderson,

    Já conseguiu resolver seu problema? Se sim, nos retorne como fez para solucionar o mesmo. Caso negativo, desmarque a resposta e responda os questionamentos do nosso amigo Rodrigo, para que possamos continuar ajudando.

    Obrigado,

    Abraço!


    Eduardo Romero

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolucao mais tarde.

    sexta-feira, 13 de março de 2015 20:10
    Moderador
  • Boa noite Rodrigo.

    Cara, não é assim, eu marco a linha 15 com o brekPoint quando aperto o botão F10 é como eu estivesse apertado o F5, ele roda o sistema normal.

    Cara ta complicado pois to so com essa maquina e dependo disso para pagar as contas, agora to me matando, pois tenho que estudar o codigo todo quando da problema.Ja desinstalei e instalei tudo, mas nada.

    É isso!


    Anderson.mds

    domingo, 15 de março de 2015 02:32
  • Olá, amigo!
    Eu tenho um projeto aqui com  7 Forms e de vez por vezes me acontece isto.

    Causas & Soluções

    Descobri que o VS 2013, como sendo mais "robusto" requer mais do desempenho do Computador. Eu fiz também várias coisas no VS, nada tinha adiantado; até que descobri que era uma "sobrecarga" no Windows. Principalmente se você trabalha com Timers, WebBrowsers ou Tabelas e BDs. Decidir deixar o Windows  mais leve, executando a limpeza de disco com o "CCleanner" e a Desfragmentação. Depois disso consegui finalmente por o "debug" em ação!

    Uma outra possibilidade de causa é algum Código travando sua aplicação. Verifique os Timers (caso use-os!). Verifique os eventos dos Objetos que estão estes códigos.

    Outra dica é por um evento "closed" no Formulário a fechar o Formulário com um "End"

    O Projeto ficando robusto fica mais lento para fechá-lo.

    Espero ter entendido e lhe ajudado.


    MS INFORMATICA


    domingo, 15 de março de 2015 03:32
  • Amigos aparece a seguintes mensagens

    use a debug build configuration or disable the debug option 'Enabled just my code'.
    check the Symbols settings under debugging option.
    to suppress this message, disable the option 'Warn if no user code on launch

    =========================

    E outra, quando levo o cursor sobre o BreakPoint percebi a seguinte mensagem

    'ponto de interrupção não sera atingido no momento, nenhum simbolo foi carregado para este documento

    É isso!!!!!!!!!!!!


    Anderson.mds

    segunda-feira, 16 de março de 2015 04:14
  • Ah! Legal, amigo!
    Agora ficou bem melhor, pois você trouxe-nos os detalhes.

    Volte a verificar o Menu, em "DEBUG", va em "Options and Settings..." e verifique:

    Para a 1ª Mensagem:

    Creio que, desmarcando essa opção já resolves a outra mensagem de "erro", que é onde, automaticamente será desabilitado o item "Warn if no user code on launch". Faça o teste e, se caso, houver mais algo, então verifique outro item a desmarcar:


    Para saber mais detalhes sobre "Debug", analise a página de Suporte do MSDN. Muito bom estes Artigos! Leia com atenção, amigo.

    Aqui tens todos os detalhes da Caixa de Diálogo de "Options and Settings" do "Debug":

    *** Caixa de diálogo Geral, Depuração, Opções ***

    Inglês:
    https://msdn.microsoft.com/en-us/library/85yzd16c.aspx

    Traduzido:
    https://msdn.microsoft.com/pt-br/library/85yzd16c.aspx

    Outros detalhes:

    SUPORTE MSDN:

    Novidades do depurador no Visual Studio 2013


    Espero ter lhe ajudado:



    MS INFORMATICA





    segunda-feira, 16 de março de 2015 06:49
  • Obrigado pessoal, mas infelismente não deu certo acho que deve ter dado pau na plataforma, vo tentar formatar a maquina é instalar o V.S 2013 novamente.

    Valeu!!!!!!!!!!!!!!!


    Anderson.mds

    terça-feira, 17 de março de 2015 18:13
  • Pessoal é o seguinte parece que o meu BrekPoint esta desabilitado, preciso abilitar o BrekPoint do visual studio 2013.

    Acho que é isso.Vi como abilitar no visual studio 2010, aparece uma janela BrekPoint, mas na versão 2013 não acho.

    Cara ta complicado.

    Clico com o botão direito do mouse encima no BrekPoint abilitar mas não funciona.Ta complicado, nimguem sabe?

    Valeu assim mesmo!!!


    Anderson.mds

    quinta-feira, 19 de março de 2015 23:24
  • 

    Anderson.mds

    segunda-feira, 23 de março de 2015 13:07
  • Amigos olha como ta, mas não para no ponto!

    Alguem pode me ajudar?


    Anderson.mds

    segunda-feira, 23 de março de 2015 13:07
  • Alguém com problema de desempenho ao desabilitar essa opção no Visual Studio 2017??? Valeu!
    segunda-feira, 28 de maio de 2018 12:44
  • Amigo, estava com o mesmo problema.. Resolvi dando um reset nas configurações, segue imagens:

    Abraços,

    Alexandre Paixão

    sexta-feira, 3 de agosto de 2018 15:20
  • Muitissimo obrigada, eu tive esse mesmo problema e essa solução resolveu!
    quinta-feira, 28 de fevereiro de 2019 18:21