locked
Ajuda em Planilha com data e prazo RRS feed

  • Pergunta

  • Boa Tarde

    Caros amigo deste blogs, eu gostaria de uma ajuda, pois eu tenho uma planilha com campos de datas e uma de prazo

    DATA DE ENVIO DO EMP DATA DE VALIDADE DATA DO SISTEMA PRAZO
    15/10/2010 25/10/2010 28/10/2010 3
    00/00/0000 10/01/1900 28/10/2010 39888
    00/00/0000 10/01/1900 28/10/2010 39888

    O que eu preciso dos amigos é o seguinte:

    você estão vendo os campos acima o primeiro é a data do envio do empenho no campo seguinte eu tenho a data de validade que a data do empenho + 10 dias o outro campo é adata do Sistema Operacional ai eu preciso alimentar o Campo PRAZO com no máximo 3 dias eu gostaria que o resultado fosse em forma de mensagem se puder claro.

    Hoje eu estou usando o seguinte vou mostrar para os amigos.

    O Campo Dt do Empenho esta na coluna " H " o Campo Dt Validade está " I " o Campo Dt Sistema está na coluna " J " e o Campo Prazo está na coluna " K ".

    Digite na coluna H uma data qualquer ai tenho o resultado usando a formula abaixo
    O Precedimento usando para eu consegui a Dt da Validade é o seguinte -----> =H8+10 ai eu tenho a Dt Validade
    Para conseguir a Dt do Sistema é o seguinte -----> =HOJE()
    Para conseguir o Campo Prazo estou fazendo o seguinte -----> =DIAS360(I8;J8;FALSO)

    Mais tenhe um detalhe quando o campo Dt do Empenho está vazio o resultado tem quer ser Campo limpo.



    Ai eu criei duas macro para gera um Auto Filtro e a outra é PrintPreview


    ActiveSheet.Unprotect
    Selection.AutoFilter Field:=10, Criteria1:="<=3", Operator:=xlAnd, _
    Criteria2:=">=0"
    Range("B14:R133").Select
    Selection.Copy
    Sheets("PRAZO").Select
    ActiveSheet.Paste

    ----------------------------

    Sub Relatorio()

    Dim wksOne As Worksheet
    Set wksOne = Application.ActiveSheet
    Range("A1:L37").PrintPreview
    wksOne.PageSetup.PrintErrors = xlPrintErrorsDash
    'ActiveWindow.SelectedSheets.PrintPreview

    End Sub

    Por favor alguém pode me ajudar nesta dor de cabeça que está sendo para me.

    Segue o meu email se alguém quiser passar alguma coisa o email é este abaixo:



    Atenciosamente

    quinta-feira, 28 de outubro de 2010 18:31

Todas as Respostas

  • Amigo,

     

    Usando a sua idéia de fórmulas pensei em mudá-las para o seguinte, sem uso de macro:

     

    Coluna de data de validade: =SE(H8="00/00/0000";"";H8+10)

    Coluna data do sistema: =SE(H9="00/00/0000";"";HOJE())

    Coluna do Prazo: =SE(H9="00/00/0000";"";DIAS360(I9;J9;FALSO))

     

    O que acha?

    Alexandre

    sexta-feira, 29 de outubro de 2010 19:14