none
Preciso de ajuda com Pin Pad RRS feed

  • Pergunta

  • Olá a todos, estou desenvolvendo uma AC com TEF Discado, no entado... (aiaiai)...

    Compramos um Pin-Pad Ingenico 3070, ok! Veio com um modem Naxos Tef Smart sei lá oq...

    fiz o cadastro com a 7PDV e a Softex, baixei o GP, Módulos da 3 bandeiras, intalei, configurei, li manual e roteiro de certificação, segui a estrutura do manual, tudo corretamente como manda a etiqueta... agora ve a minha dúvida!

    A M* do PinPad Ing@nico 3070 não funciona, veio sem driver, tá, é serial, ok... mas todas as portas COM q aponto na config dos módulos dão "Erro ao iniciar PinPad [0]" ou "Erro ao comunicadar com Porta COM [2]"... caramba... já instalei, desinstalei, configurei, desconfigurei, adicionei porta, retirei porta, já quebrei monitor, teclado, mouse e quase quebro minha mão de raiva...

    Eu peço incarecidamente, por gentileza, por obsequiuuu.... por todos os santos existente no plasma do universo
     "ME AJUDEM!!!"

    ps: desculpem meu desespero, é que tenho que homologar isso pra ontem!
    terça-feira, 2 de outubro de 2007 23:41

Respostas

  •   Boa tarde:

     sou oTalles do grupo pão de açucar.

     Você precisa de um, programa para gerar os sub-grupos.

     Esses  modelos de pin- pad não funcionão sem o sub grupo.

     Sub grupo é uma chave eletronica que faz a comunicação da loja com o banco,

     Transferencia entre contas.

    domingo, 12 de fevereiro de 2012 19:34

Todas as Respostas

  •  

    Amigo, sei exatamente o que você está passando. Mas não se estresse não porque não resolve. Vamos passo-a-passo pra chegarmos numa solução:


    01 - O maior problema do TEF não é o desenvolvimento em si, mas sim a comunicação serial e do modem. São os dois dispositivos mais complicados e instáveis de um computador. Por isso é que devemos tomar cuidados básicos com a porta. Nunca conecte o cabo serial na cpu com o pin-pad ligado e nem da impressora. Às vezes, ou seja, quase sempre dá um curtozinho e a porta pára de funcionar. Como resolver isso? Você pode fazer de duas formas: a primeira é reiniciando o micro e a segunda é desinstalando a porta serial no gerenciador de dispositivos e logo apos desativar verificar novo hardware e o xp detectará a mesma já com o problema resolvido. Lembre-se disso!

     

    02 - O meu pin-pad é o mesmo modelo do seu e funciona beleza, já o modem meu amigo!!!! Esse modem!!!! Esse modem me dá até dor de cabeça quando lembro desse nome NAXOS TEF SMARTLINK. Meu Deus! Isso não funciona nem com string e nem com "float". Tô brincando! É que o pessoal da Seven passa umas strings que não funcionam, mas eles garantem que funciona mas não funciona. Nem lá na hora da homologação não funciona. Esse negócio de modem é coisa do passado! Mas fazer o quê né?
    Conselho em relação ao pin-pad: Não tem segredo. Não tem driver, não precisa de nada. É muito simples. Se não está comunicando te garanto que o bug é na porta. Isso aí é certeza. Só lembrando que o Configurador Visanet tem um bug na hora de testar o pin-pad. Você tem que pressionar F5 pra testar o pinpad porque o botão fica inativo. Já na redecard também tem um bugzinho. A porta está certa e ele diz que a porta está errada. Mas é o seguinte: se você sabe que a porta está certa clique no botão confirmar. Ao entrar novamente clique novamente em testar comunicação e aí sim você verá que está funcionando e um segundo antes a redecard avisava que a porta estava errada. É isso aí amigo! Tá pensando que só os nossos sistemas que têm bugs. Rapaz até o GP tem os dele. E o pessoal da certificação tem coragem de defender o GP. Hummm! Quando vc for homologar veja a versão nova da visanet (v30) tem bugs de foco. Mas vamos lá. Próximo passo!

     

    03 - Quanto ao modem, eu comprei só 3 naxos. Pensei que o problema fosse o primeiro, então comprei o segundo e daí pensei...É! Pode ser que os dois estejam bugados! Vamos comprar o terceiro! É só 174,00 cada um. E novamente bug de novo. Comprei duas US ROBOTICS e nada. Isso tudo com as strings passadas pela Seven e nada de funcionar.
    Tive que sair do Pará e ir pra São Paulo pra resolver a parada por lá mesmo. Foi aí que surgiu a Trellis maravilhosa. Oh! Meu Deus que coisa perfeita. Todos os meus problemas se acabaram! Só que tem um detalhe: a Trellis não funciona com a string que a Seven passa pra gente. A string que funcionou foi um técnico do suporte da Trellis que me passou. Aí sim foi um abraço!

    04 - Só mais uma dica. Lembre-se dos bugs das portas seriais e sempre que houver falha de comunicação suspeite delas. Remova-as e as instale novamente. Quanto ao pin-pad teste em outras duas máquinas pelo menos. Não precisa de driver e quando funciona só aparece uma figurinha pequena no canto. Mas quando fazemos o teste de comunicação da visanet, pede pra digitar 123456. Quanto ao modem, troque-o imediatamente e sucesso pra você meu irmão porque a caminhada é mais longa do que imaginamos.

    Grande abraço e boa sorte!

    quarta-feira, 3 de outubro de 2007 03:26
  • Olá Gildicley;

     

    Tudo bem cara?

     

    Ae, tem algum santo com o seu nome??!?!? Se não tiver vou pedir Canonização a você!!! Vc é um Santo cara...

    Ano que vem vou para N.S. da Aparecida acender uma vela de 2mt de altura para sua pessoa!!!

     

     

    Então, funcionou cara... Acho que o maior problema era o bug com os softwares dos módulos... que ou não deixava testar o pin-pad ou dava erro (quando não era erro) quando estava funcionando...

    Agora estou fazendo os testes com Amex e Redecard para testar e terminar a parte do TEF e depois farei o teste com a VisaNet para pegar a parte do modem, ainda não cheguei lá, mas realmente o NAXOS não funcionou por enquanto... mas já estamos procurando um Trellis!

     

    Só uma dúvida, como empresas tão grandes como estas 3 bandeiras e mais 2 empresas como a 7PDV e a SoftwareExp podem liberar uns softwares tão buguento assim??? Para o nivel destas empresas o setor de qualidade tem que ser mais refinado... Será que é a falta de concorrencia, eles sabem que o mercado é deles por isso não tem preocupação em estar sempre fazendo o melhor que o concorrente??? Se eu desenvolve um software desse e libero desta forma, com certeza sou demitido aqui na empresa... Mas fazer oq, supremacia para quem tem $ e boa sorte ao resto!

     

     

    Cara, valeu pela dica! 100% proveitosa!

     

     

    Abraços!!!

    quarta-feira, 3 de outubro de 2007 18:24
  • bom dia

     

    amigos deixem-me entrar nessa briga kkk. Cara tenho o tef todo pronto e com todas as funções em visua fox pro prontas e testadas. Acontece que agora foi feita uma nova versão do gerenciado da visanet esse mesmo que vc estão tendo erros, e preciso mudar o meu programa pra essa nova realidade. Já falei com o pessoal da sevenpdv, ele me passaram alguns doc mais não encontrei neles nda falando ondeeu tenho que mudar o sistema. Pergunto? vcs sabem de algo ou algum luigar que eu ache essas informações

     

     

    agradecido

    quarta-feira, 10 de setembro de 2008 12:57
  • primeiro...


    gerenciador de dispositivos , verifica qual porta ele esta , quando usada placas multiseriais ele muda a com...

    cria um arquivo .ini no teu programa para o pinpad..

    tipo um clisitef.ini...

    dentro coloca parametros de funcionamento do pinpad...

    e o resto e com vc...


    abraço
    quarta-feira, 7 de janeiro de 2009 19:03
  • Mas os testes do roteiro Visanet são feitos usando o Gerenciador Padrão e o módulo Plug&Pay. Já fiz todos eles e estou indo homologar dia 20. E este módulo faz as transações todas em off. Não tem necessidade de configurar o modem, pois não é feita nenhuma conexão com o servidor deles.
    Uma dica boa também para a questão do pin-pad serial, é reservar recursos de IRQ na BIOS da sua máquina. Pois na hora que começar a rolar os testes com desligamento de CPU, vc vai endoidar.
    Boa sorte e que os anjos estejam contigo.

    quarta-feira, 7 de janeiro de 2009 22:00
  • Galera, boa tarde. Tô com um problema, eu tava testando tudo bonitinho no visanet e agora do nada começou a fazer o seguinte, abre a tela do Plug&Pay e antes de dizer passe o cartão, a tela fecha. Não tem santo que faça funcionar, sendo que estava funcionando bonitinho antes. Já desinstalei e reinstalei de novo, dai funciona da primeira vez e depois não funciona mais. Alguém passou por isso? Pode me dar um help?
    Barbara Fidelis
    quinta-feira, 17 de setembro de 2009 20:54
  • Galera, boa tarde. Tô com um problema, eu tava testando tudo bonitinho no visanet e agora do nada começou a fazer o seguinte, abre a tela do Plug&Pay e antes de dizer passe o cartão, a tela fecha. Não tem santo que faça funcionar, sendo que estava funcionando bonitinho antes. Já desinstalei e reinstalei de novo, dai funciona da primeira vez e depois não funciona mais. Alguém passou por isso? Pode me dar um help?
    Barbara Fidelis
    Boa noite!

    Pode ser que exista alguma transação pendente de confirmação. Neste caso o gerenciador irá fechar e no arquivo de resposta vai ter a informação do porque da não continuação.

    Posta aqui pra gente o arquivo de resposta logo após a tela fechar antes de pedir o cartão.

    T+
    quinta-feira, 17 de setembro de 2009 21:26
  •   Boa tarde:

     sou oTalles do grupo pão de açucar.

     Você precisa de um, programa para gerar os sub-grupos.

     Esses  modelos de pin- pad não funcionão sem o sub grupo.

     Sub grupo é uma chave eletronica que faz a comunicação da loja com o banco,

     Transferencia entre contas.

    domingo, 12 de fevereiro de 2012 19:34