none
página asp no visual studio RRS feed

  • Pergunta

  • pessoal,

    tenho um projeto em vb.net e algumas pastas que tem conteúdo só em asp clássico.. quando executo meu projeto local, beleza.. as páginas funcionam direitinho.. mas quando tento abrira página em asp clássico não funciona..

    o que preciso fazer pra rodar essas páginas em asp local?

    quinta-feira, 27 de dezembro de 2012 11:45

Todas as Respostas

  • Kyrla,

    Você está usando seu VS integrado com o IIS ou a cada execução ele gera aquele server com porta e tudo mais?

    Se for no IIS é fácil só seguir esse tutorial que da tudo certo:
    http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis

    Já no VS eu não tenho ideia!

    Espero ter ajudado e não esqueça de marcar se a resposta te ajudar!


    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    quinta-feira, 27 de dezembro de 2012 12:46
  • não.. é direto do VS mesmo.. só dou F5 e ele executa pra mim lá..
    quinta-feira, 27 de dezembro de 2012 12:56
  • Entendo...mesmo assim acredito que você tenha o IIS instalado na maquina, veja os primeiros passos do link que eu postei se funcionam.

    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    quinta-feira, 27 de dezembro de 2012 14:33
  • Veja esse link http://stackoverflow.com/questions/3453762/debugging-classic-asp-in-visual-studio-2010 a solução é para 2010 mas funciona no 2005/2008/2010/2012.

    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    quinta-feira, 27 de dezembro de 2012 14:39
  • Se eu não me engano o ASP não vai rodar de jeito nenhum se você não instalar / habilitar o IIS. Por isso vale a pena dar uma olhada nos links dos colegas acima e verificar se o IIS está instalado / habilitado E também se ele está rodando páginas ASP. Por default o IIS não roda ASP3 se eu não me engnao. Abs

    []'s --- Se a minha resposta lhe foi util, marque "Propor como Proposta" para qualificar o conteudo do fórum e ajudar os outros usuários. Obrigado, Valdek Santos Santana Junior

    segunda-feira, 21 de janeiro de 2013 14:45
  • Pessoal, eu postei um problema para rodar ASP clássico no Win7 com iis 7.5...

    Se puderem responder eu agradeço...  foi o seguinte:

    "Erro ao RODAR ASP Clássico no Win7 com iis7

    Pessoal,

    Eu tenho que dar manutenção em um site escrito em ASP e para isso preciso fazê-lo funcionar em minha máquina com Win7 e iis 7.5.7600.16385.

    Acontece que mesmo configurando o iis, quando rodo a página no 127.0.0.1:81/leilajo/web /index.asp dá o seguinte erro e não sei mais como resolver:

    • An error occurred on the server when processing the URL. Please contact the system administrator.If you are the system administrator please click here to find out more about this error

    Bom, o que preciso fazer?

    O meu usuário é administrador, dei permissão de admin para todos os usuários e nada! Na pasta do projeto eu deixo ela livre para leitura e gravação, mas acho que o iis ou sei lá o que, muda as propriedades/atributos e deixam ela com o checkbox preenchido.

    Vale ressaltar que a configuração apresentada no site http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis  foi seguida para: Installing Classic ASP on Windows Vista or Windows 7 Client, 

    sendo que não funciona!!! o erro acima continua!

    Grato,

    Gilberto"

    Talvez esse seja o mesmo problema da Kyrla, não?

    quarta-feira, 27 de março de 2013 02:50