none
Compilar projeto Analysis Services RRS feed

  • Pergunta

  • Meus amigos preciso de ajuda com este tema. Quando dou um Deploy em minha solucao para que me crie os Cubos no Analysis Services me da as seguintes mensagens com exemplo de dois usuarios.

     

    Erro quando entro com o usuario Administrador

     

    Error returned by underlying Operating System call. Error Code = 0xC1010000, External Code = 0x00000534: No mapping between account names and security IDs was done.

     

    Porque com o Adminsitrador nao me deixa dar um Deploy ?

     

    Erro quando entro com meu usuario em teoria tenho os mesmo direitos do Adminstrador.

     

    Error 1 Either the 'HUNTERDOUGLAS\reinaldo_ferreira' user does not have permission to alter the 'OLAP - Hunter Douglas' object, or the object does not exist.  0 0 

     

    No meu usuario fica claro que nao tenho direitos para criar ou alterar no Analysis, aqui onde atribuo este direito ? E algum direito no AD que esta me faltando ?

     

    Obrigado.

     

     

    segunda-feira, 24 de setembro de 2007 20:40

Respostas

  • Bom dia,

    Abra o projeto diretamente no Business Intelligence development studio...

    - Expanda a opção "Roles"...

    - Verifique se foi criado alguma Role (regra de acesso)

    - Se não foi criado adicione uma

            - Na aba "Membership" adicione o usuário que vc quer dar acesso (por default os administradores da máquina possuem acesso)

           

    - Se já existe uma Role

            - Remova os usuários na aba "Membership" e adicione-os novamente.

            - Na aba "Cubes", verifique se todos os cubos estão com a coluna "Access" seleciona como read

     

     

    Geralmente, só remover e adicionar os usuários já resolve o problema.

     

    Abraço

    terça-feira, 25 de setembro de 2007 11:27

Todas as Respostas

  • Boa tarde Reinaldo,

     

     

    Este erro que ocorre quando voce entra com user adminstrador parece ser algum relacionamento entre as tabelas do data source view que voce criou, de uma resvisada no seu data source view. Se nao for isso, verifique se seu DW esta consistente.

     

    O segundo erro, com usuario criado, eh relativo. Esse usuario teria os mesmos acessos que o administrador caso ele esteja criado COMO ADMINISTRADOR na base do SSAS, no banco (creio que precisa tambem), e talvez ateh no diretorio fisico onde seu cubo esta sendo armazenado.

     

    Crie esse usuario no banco onde esta o DW, nas roles do SSAS onde esta seu cubo e tambem de permissao nos diretorios do servidor onde esta o cubo.

     

    Espero que ajude.

     

    Abraços!

    segunda-feira, 24 de setembro de 2007 20:53
  • Bom dia,

    Abra o projeto diretamente no Business Intelligence development studio...

    - Expanda a opção "Roles"...

    - Verifique se foi criado alguma Role (regra de acesso)

    - Se não foi criado adicione uma

            - Na aba "Membership" adicione o usuário que vc quer dar acesso (por default os administradores da máquina possuem acesso)

           

    - Se já existe uma Role

            - Remova os usuários na aba "Membership" e adicione-os novamente.

            - Na aba "Cubes", verifique se todos os cubos estão com a coluna "Access" seleciona como read

     

     

    Geralmente, só remover e adicionar os usuários já resolve o problema.

     

    Abraço

    terça-feira, 25 de setembro de 2007 11:27