none
Problemas Reporting Services ! (Vista Ultimate(X64) e SQL 2005 standard) RRS feed

  • Pergunta

  •  

    Boa Tarde a todos!

     

    Estou tendo um problema na instalação ou configuração do  Report services!

     

    Instalei o visual studio 2005 professional (SP1)

    instalei o IIS 7 do vista (em painel de controle-> add e remover componentes do win)

    depois o SQL Server 2005 Standard Edition(SP2).

    Achei Estranho q na hora da instalação o report services não estava disponivel(check box).

    Tanto que eu  entro no report manager e ele nao localiza nenhum server na maquina, eu gero meu rs no  business inteligence, configurei para  http://localhost/Reportservices  , fui em project  deploy e ficou  pedindo um usuario e senha !  no qual eu nao cadastrei!!

     

    oque devo fazer?  desinstalar  tudo  e alterar a ordem de instalação! ou tem algo que eu possa arrumar ?

     

    SO: vista ultimate (x64)

     

    quarta-feira, 7 de maio de 2008 16:31

Todas as Respostas

  •  

    Bom dia Patrick,

     

    A página padrão para o report server é http://localhost/Reporserver só confirmando que você está usando a que voce realmente configurou. Quando você entra na tela de configuração (Configuration Tools/Reporting Services configuation Manager) você tem algum item em "vermelho", isso quer dizer que você pode ter alguma configuração pendente.

     

    Att

    Boreki

    quarta-feira, 7 de maio de 2008 17:11
  •  

    ai que esta o X da questão ! quando eu vou em  reporting services configuration  manager ,  e aperto o botao find ele fala que nao encontra o  servidor  e por assim vai !  tanto que  quando eu vou no management studio  e seleciono o report server ele nao consta nada!   ai que esta eu teria que instalar meu sql novamente ?-

     

    abraz

    Patrick

    quarta-feira, 7 de maio de 2008 18:06
  • Patrick,

     

    Cara já passei por este problema no Vista UItimate 32, realizei alguns alterações na configuração do serviço do Reporting Services, foi um pouco complicado mas depois funcionou.

    quarta-feira, 7 de maio de 2008 18:48
  • Só mais uma pergunta! você me recomendaria remover o SQL?  

    instalaria o IIS7 primeiro depois o visual studio depois o SQL ou a ordem nao altera os resultados?

    obrigado

    quarta-feira, 7 de maio de 2008 19:41
  • Patrick,

     

    Antes de reinstalar verifique se o serviço do reporting services está instalado e rodando (painel de controle, ferramentas administrativas/Serviços/Microsoft Sql Server Reporting Services). Se não estiver, tente iniciá-lo manualmente. Se existir algum problema ao inicializar o serviço ele irá registrar um log no Event Viewer ou no arquivo de log na pasta do reporting services/LogFiles.

     

    As vezes analizando estes arquivos fica mais fácil de ter uma idéia da razão pela qual você está tendo problemas. Se estiver faltando algum pré-requisito (ex. algum componente do IIS ou algo do genero) e você tentar reinstalar você pode acabar na mesma situação.

     

    Você falou que na hora da instalação o "check box" do reporting services nao estava disponível, Ele apareceu na lista de componentes a serem instalados durante a instalação?

     

    Att

    Boreki

     

    quarta-feira, 7 de maio de 2008 20:38
  • Então na hora da instalação o checkbox estava(disable). no caso como se nao estivesse disponivel! 

    E nos serviços não consta o serviço  report services!. No caso não deve  ter sido instalado mesmo!

    Mais ja desinstalei tudo  e voltando da facul vou instalar ! e agora e pra dar certo!

     

    Obrigado a todos !!!

     

    amanha vou postar o resultado dessa nova instação!

     

    Patrick

     

     

    quarta-feira, 7 de maio de 2008 22:46
  •  

    Ocorreu o seguinte erro de requerimentos na hora da instalação

     

     

    - ASP.Net Version Registration Requirement (Warning)
     Messages
     * ASP.Net Version Registration Requirement
     
     * Failed to find the ASP.Net Version Registration with Microsoft Internet Information Services (IIS).

     

     

    o detalhe e que eu ativei o .net e i asp.net no  iis

     

    nao sei mais oque fazer Sad

    quinta-feira, 8 de maio de 2008 17:20
  •  

    ontem na busca incessante testei mais duas coisas porem nao deu certo

     fui no prompt :

    microsoft.net\framework\v2.0.xxx  e digitei  aspnet_regiis -i( fala que  o iis nao esta ativo)

    microsoft.net(x64)\framework\v2.0.xxx  e digitei  aspnet_regiis -i  (instala com sucesso)

     

    porem mesmo assim nao funcionou !

     

    o iis esta ok se eu digito http://localhost  ele aparece o simbulo do iis7

     

     

    tem mais alguma coisa que eu possa fazer para que nao de mais o erro de asp.. sera que esse problema esta acontecendo por causa da versao x64 e meu sql server e  x86 ?

     

    sexta-feira, 9 de maio de 2008 10:44
  • Bom dia Patrick,

     

    Dá uma olhada neste link:

    http://support.microsoft.com/kb/920201/en-us

     

    E verifique que voce tem todos esses componentes instalados:

    Component Folder
    Static Content Common HTTP Features
    Default Document Common HTTP Features
    HTTP Redirection Common HTTP Features
    Directory Browsing Common HTTP Features
    ASP.Net Application Development
    ISAPI Extension Application Development
    ISAPI Filters Application Development
    Windows Authentication Security
    IIS Metabase Management Tools
    IIS 6 WMI Management Tools

     

     

    Att

    Boreki

    sexta-feira, 9 de maio de 2008 16:41
  •  

    Boreki   eu fiz os seguintes procedimentos:

     

    1.

    No Painel de controle, clique programas , e clique clique duplo programas e recursos .

    2.

    Na caixa diálogo User Account Control clique, Continuar .

    3.

    Clique em Recursos Turn Windows ativado ou desativado .

    4.

    Na caixa diálogo Windows Features , expansão Serviços de Informações da Internet expansão, Ferramentas de Gerenciamento da Web , expansão IIS 6 Management Compatibility , e seguida, clique para selecionar o seguinte caixas verificar:

    Compatibilidade WMI IIS 6

    Compatibilidade configuração IIS Metabase e IIS 6

    5.

    Expanda Serviços W3 (World Wide Web) , expansão Application Development Features , e seguida, clique para selecionar o seguinte caixas verificar:

    ASP.NET

    Extensões ISAPI

    Filtros ISAPI

    6.

    Expanda Recursos HTTP comum , e seguida, clique para selecionar o seguinte caixas verificar:

    Documento padrão

    Navegação Diretório

    Erros HTTP

    Redirecionamento HTTP

    Conteúdo estático

    7.

    Expanda de segurança , e seguida, clique para selecionar a caixa verificar Autenticação do Windows .

     

    e mesmo assim nao da certo ! da um erro de ASP.

    sexta-feira, 9 de maio de 2008 16:59
  • Patrick,

     

    Você fez tudo isso antes de instalar o Reporting Services? Pelo que entendi a "checkbox" do RS não estava habilitada quando você instalou. A razão para isso é que algum dos pré-requisitos não estava preenchido. Após habilitar todos esses componentes do IIS você tentou reinstalar o RS?

     

    Att

    Boreki

    segunda-feira, 12 de maio de 2008 16:01
  • O triste e que sim !   tentei reinstalar o sql 2005 novamente mais mesmo assim ele da erro de asp,  e com isso eu nao consigo habilitar o report services(no caso o botao fica desabilitado).

    desinstalei tudo !  e fiz o seguinte processo e tambem nao deu cerrto ! instalei o iis, visual studio, e sql2005, porem nao habilita o report services pois o asp 2.0 para o framework(x86) nao instalala pois nao reconhece o iis7! agora o framework(x64)instala normalmente o asp so que o sql por ser x86 utiliza o framework x86 e por isso nao funfa! (mor bagunça)

     

    Obrigado

     

    Patrick

    segunda-feira, 12 de maio de 2008 16:08
  •  

    Patrick,

     

    Não sei se esse post vai te ajudar, mas é uma instalacao de RS em um vista 64.

    http://sqlblog.com/blogs/andy_leonard/archive/2007/12/08/installing-virtual-server-on-vista-ultimate-64-bit.aspx

     

    E voce chegou a instalar o sp2?

     

    Att

    Boreki

    segunda-feira, 12 de maio de 2008 16:40