none
problemas no recebimento da Pagina... Browser?? RRS feed

  • Pergunta

  • não sei se esse é o local mais apropriado para este topico... se não for, avisem-me...
    Esta ocorrendo umas coisas estranhas num sistema que estou desenvolvendo... as vezes, em algumas maquinas, com windows 98.. qndo esta carregando a pagina o browser simplismente para de receber a pagina do servidor... e depois de + ou - um minuto, a pagina esta totalmente carregada e funcionando....
    
    imaginei que poderia ser algo na minha pagina que estaria provocando uma 
    demora na saida do servidor, mas se fosse isso, deveria ocorrer em todas as maquinas e sempre...
    
    enfim... oque pode ser?? sera o Browser do cliente??? ou sera no servidor??  como posso checar se as informações estao saindo do servidor??
    existe alguma forma de debugar a execuçao da pagina no servidor??
    ou algo que eu posso ver as estatisticas de geração das paginas???
    terça-feira, 25 de julho de 2006 17:38

Todas as Respostas

  • Acho que já vi esse problema.

    Se não me engano era problema relacionado a BUFFER...

    buffer="on"

     

    Se tiver essa linha na sua app. tente removê-la e veja se resolve.

     

     

    Espero ter ajudado!

    quarta-feira, 26 de julho de 2006 19:09
  • não...não tem essa opção em nenhum lugar da aplicação....

    as configurações de buffer não estariam nas configurações da aplicação no IIS??

    mas não acredito que isso resolva...o problema estaria na maquina cliente talves. só ocorre em maquina com WIN 98...

    quarta-feira, 26 de julho de 2006 19:47
  • acabei de fazer uns testes de estatisticas de geração da pagina, a pagina foi gerada no servidor em 31 milisegundos, mais demorou 2 minutos para chegar ao cliente.... é realmente estranho é que ocorre com win 98, e apenas em uma pagina...

    agora parece estar claro que o problem é lado do cliente e não no servidor.....mas oque poderia ser???

    [para calcular o tempo de geraçao da pagina eu peguei a hora atual, now(), no começo do evento page_load da pagina, e a hora atual no page_unload, depois fiz o calcula da diferença entre as dois horarios..... algo de errado neste procedimento?]

    quinta-feira, 27 de julho de 2006 13:14
  • acabei de notar que isto esta ocorrendo qndo abro uma pop-up com window.open(...), a popup é carregada normalmente, mas a outra demora muito...
    quinta-feira, 27 de julho de 2006 13:43