none
CRM 4 - Edição em massa RRS feed

  • Pergunta

  • Boa tarde pessoal,

    Tenho 2 entidades customizadas que estão vinculadas uma com a Conta e outra com o Cliente potencial.

    Quando seleciono varios clientes potenciais e clico em editar (edição em massa), o campo referente a esta entidade fica trancado e não consigo alterar. Porém quando faço o mesmo processo na Conta, consigo alterar.

    Alguém sabe me dizer o porque? É tributo? Direito de acesso? (Estou como Administrador).

    Obrigado!



    quinta-feira, 27 de dezembro de 2012 16:42

Respostas

Todas as Respostas

  • Boas,

    Encontrei este artigo que pode ter a solução para o teu problema. Dá uma olhada:

    http://links.dynamicscrmteam.com/2011/08/08/disabled-fields-in-bulk-edit-form-%E2%80%93-crm-2011/

    Espero ter ajudado


    Pedro Azevedo Crm Specialist 4.0\2011

    • Sugerido como Resposta Azevedo PedroMVP quinta-feira, 27 de dezembro de 2012 17:45
    • Marcado como Resposta Geraldo S Junior sexta-feira, 28 de dezembro de 2012 13:14
    quinta-feira, 27 de dezembro de 2012 17:45
  • Fala Pedro,

    Ajudou sim, mas acredito que tenha alguma coisa nativa não tem?

    Pois, como pode uma entidade permitir e a outra não?

    Abraços!

    quinta-feira, 27 de dezembro de 2012 19:00
  • Boas Geraldo,

    Mas conseguistes resolver o teu problema?

    Aquilo que percebi é que quando temos um evento onchange associado ao campo este aparece automaticamente disabled na edição em massa. Numa entidade tinhas o evento e na outra não? Ou a propriedade BehaviorInBulkEditForm tinha valores diferentes nas duas entidades?

    Eu considero este comportamento nativo. Mas penso que não existe outra maneira por exemplo via configurações do crm.

    PS: Se o teu problema foi resolvido podes por favor colocar o meu post como resposta e\ou como útil. Obrigada.


    Pedro Azevedo Crm Specialist 4.0\2011

    sexta-feira, 28 de dezembro de 2012 10:47
  • Olá Pedro, 

    Era isso mesmo, muito obrigado.

    Desabilitei o evento Onchange do campo momentaneamente para conseguir realizar a edição em massa, depois habilitei novamente.

    Abraços!!

    sexta-feira, 28 de dezembro de 2012 13:14