none
duas procedures em um único relatorio RRS feed

  • Pergunta

  • Tenho um ralatório que estou montando em report viewer onde tenho duas procedures uma trás os totais e a outra trás os campos, criei um datasource e criei um tableadapter para cada procedure e não sei como vou colocar essas duas tabeladapter no mesmo relatório isso é possível ?

    Eu já tenho esse relatório pronto mais nao fiz com report viewer e sim apenas montei a página e acessei as procedures via ADO e montei o relatório digamos que na mão, mais quero agora fazer esse mesmo relatório pelo report viewer. Alguém tem alguma idéia ?


    Junior
    quinta-feira, 29 de setembro de 2011 14:12

Todas as Respostas

  • Bem, crie um dataset

    crie uma tabela no dataset

    popule a tabela do dataset com a SP 1

    popule a tabela do dataset com a SP 2

    mostre a tabela do dataset no report viewer.

    sexta-feira, 30 de setembro de 2011 14:03
  • Paulo, fiz assim, criei 2 dataset cada um apontando para um SP, sendo que as duas SP tem os mesmos parametros então só para testar criei uma table a associei ao dataset que mostra os dados, o relatório executa mais não mostra nada, criei os parametros mais como eles são os mesmos para as duas SP acho que tenho que informar no parametro para qual dataset ele é vinculado, executo o relatório mais os dados não são mostrados.

     

     


    Junior
    sexta-feira, 30 de setembro de 2011 14:27
  • Junior, tentou executar as SP e atribuir os dados retornados para DataTables diferentes?

    Digo, em seu DataSet, atribuir a SP1 para o DataTable1 e o SP2 para o DataTable2. Depois use o método Merge do DataSet para mesclar as informações em uma só e aplique no seu relatório.


    Leonardo Borges 'Xis'
    "Mas a persistência é o que leva a perfeição."
    Se a resposta for útil, marque-a. Poderá ser útil para outros desenvolvedores.
    sexta-feira, 30 de setembro de 2011 19:57
  • Leonardo se eu fizer esse merge qual dataset eu seto no relatório ? pq no reportviewer coloquei 2 dataset um para cada datable que criei, mais estou mais intrigado pq para fazer uns testes criei uma table e setei ela para o dataset que trás os dados, mais ele nao é preenchida com nada, só aparece o cabeçalho, é como se ele não me trouxesse nada, antes estava com erro, eu acho que era a passagem de parametro.

    Existe alguma forma que de ver se ele está executando o select do tableadapter, pq no wizard se coloco preview data e informo os parametros ele me trás um resultado, mais no relatório não trás.

     


    Junior
    segunda-feira, 3 de outubro de 2011 13:38