none
Substituir um valor dentro de um PROCV RRS feed

  • Pergunta

  • Estou fazendo uma fórmula que utiliza PROCV. Porém, o intervalo de busca muda sempre. Por exemplo, uma hora o range será da célula A5 até a célula I2000; Noutra ocasião, o range será de A20 até I2000. Isto dependerá de uma variável que mudará de acordo com a pesquisa do usuário. 

    Para mudar este range automaticamente, montei uma fórmula que me dá o resultado exato de onde o mesmo deverá iniciar a pesquisa.

    O problema é que não consigo mudar isto dentro do PROCV de forma automática.

    Tentei fazer uma macro simples (com o Editor de Macro) onde eu copio o valor da célula onde fiz a fórmula que me dá a célula onde o range deverá começar; depois eu utilizo o Ctrl U e colo o resultado da cópia.

    Mas quando vou ver a Macro, este valor copiado fica fixo, ou seja, se eu mudar os argumentos e repetir a macro, o resultado continua o mesmo.

    Tem algum jeito de mudar isto?

    sábado, 18 de janeiro de 2014 22:50

Todas as Respostas

  • Boa noite Alberto.

    A solução é bastante simples, basta usar a função 'Indireto'.

    Exemplo: suponha que em 'A1' esteja o intervalo desejado 'A5:I2000'. Para usar como intervalo, use: '=PROCV(ValorProcurado;INDIRETO(A1);ColunaDesejada;0)'.

    Entendeu?


    Filipe Magno

    sábado, 18 de janeiro de 2014 23:29
  • Seria melhor se você postasse a fórmula que está usando aqui e até a macro que utilizou.

    Minha sugestão é que você use o PROCV para varrer a coluna por completo, como em:

    =PROCV(C1;A:B;2;0)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    domingo, 19 de janeiro de 2014 15:23
    Moderador