none
PROCV + SE - Excel RRS feed

  • Pergunta

  • Bom Dia

    Não estou conseguindo montar a formula de procv para minha planilha.

    Tenho 2 planilhas

    uma com 4 informações: matricula, Aluno, Dados dos alunos, valores 

    outra com 3 informações: matricula, um determinado dado (nesse ex Inglês), e o valor referente ao dado da segunda coluna)

    Ex: 001 / João/  Endereço/ Rua bLABLA
          001/ João/  Matematica / 8,0
          001/ João/  Inglês / 6,0
          002 / Maria/  Endereço/ Rua fim da rua
          002/ Maria/  Matematica / 7,5
          002/ Maria/  Inglês / 9,0

    Preciso q localize na primeira planilha a matricula X (002) e Dado x (Inglês) então retorne para a minha segunda planilha o dado referente a Inglês daquela matricula.


    Desde já obrigado a todos!

    sexta-feira, 6 de fevereiro de 2015 11:28

Todas as Respostas

  • Rhenner,

    Para que esse PROCV funcione corretamente, você precisar criar uma referência única.

    Como eu faria:

    1. Inserir uma nova coluna (A) na planilha 1;
    2. Concatenar na coluna A os valores Matrícula & Dado na planilha 1;
    3. Inserir uma nova coluna (A) na planilha 2;
    4. Concatenar na coluna A os valores Matrícula & Dado na planilha 2;
    5. Na planilha 2 buscar pelos valores da coluna A e utilizar os valores das células da coluna A como referência.

    Abraço,


    Carlos Eduardo Ferreira

    • Sugerido como Resposta Livia Gerbeli domingo, 22 de fevereiro de 2015 21:04
    quinta-feira, 19 de fevereiro de 2015 19:54
  • Para procurar e retornar valores de outras planilhas Excel você pode fazer dessa maneira abaixo:

    Onde:
     1 - Parâmetro é a coluna que quer coincidir com o outro arquivo (coluna com a matricula por exemplo);
     2 - Caminho do arquivo conforme abaixo+Sheet (nome da aba);
     3 - $A$1 ->coluna inicial de pesquisa , $D$8-> Coluna Final de pesquisa;
     4 - 3 - >Retorno o item que esta na terceira coluna;
     5 - 1 - >Retorna verdadeiro se encontrar; 

    =PROCV(A1;'caminho_do_arquivo\[DADOS1.xlsx]Plan1'!$A$1:$D$8;3;1)


    • Sugerido como Resposta Mr. GMSOFT quinta-feira, 19 de fevereiro de 2015 20:36
    quinta-feira, 19 de fevereiro de 2015 20:36
  • Conseguiu resolver seu problema?

    Se sim, feche seu thread, por favor.

    Carlos Eduardo Ferreira

    terça-feira, 9 de junho de 2015 17:45