locked
Localizar um valor entre uma Variável RRS feed

  • Pergunta

  • 1 - Tenho uma tabela com valores mínimos e máximos em 5 níveis diferentes (tabela abaixo), e um campo como critério (quantidade)
    2- Camo fazer para determinar que o excel faça um cálculo desde que o critério esteja dentro dos níveis min. e max?

    Tabela

    Min Max
    1000 1245
    2000 2490
    3000 3735
    4000 4980
    5000 6225


    Critério = 999 não fazer a conta
    Critério = 1246 não fazer a conta
    Mas se estiver dentro do min e max, fazer a conta

    quarta-feira, 16 de setembro de 2009 03:11

Todas as Respostas

  • Tem como você me mandar a planilha por e-mail, para que eu posso entender melhor?

    Ja adiantando, imagine que o seu mínimo esteja na coluna "C" e o seu máximo na coluna "D"
    Você precisa definir em outras células sua faixa de trabalho, tipo na cálula a1 você determina seu mínimo.
    E na célula B1 seu máximo.
    ai na coluna E, em cada linha coloque a seguinte fórmula

    =SE(E(C1<A1;D1<B1);SUA FÓRMULA;"")

    ONDE ESTA NA FÓRMULA ESCRITO SUA FÓRMULA.
    SUBSTITUA PELOS CÁLCULOS QUE VOCÊ QUER QUE O EXCEL FAÇA.

    se tiver dúvidas, me mande a planilha por e-mail.

    ahorta@yamana.com

    Abraço

    Se suas expectativas foram atendidas, não esqueça de maracar como respondido

    Abraço
    ...
    quinta-feira, 17 de setembro de 2009 12:46
  • Amigo até eu mesmo lendo achei bem complicado, mas acredito que agora ficará mais claro



                   Colunas
    Linhas          A           B                   
    1              MIN       MAX       
    2            1000   a   1245           
    3            2000   a   2490      
    4            3000   a   3750
    5
    6
    7            quant(critério)
    8              1100


    Preciso que, o excel localize se a quantidade informada no critério (A8) está dentro de uma das faixas de min e max (A2:B4) e se positivo execute uma formula caso negativo outra formula.

    Exemplo
    01) A8 = 900   resultado negativo
    02) A8 = 2200 resultado positivo

    é isso

    grato
    sábado, 19 de setembro de 2009 20:59
  • Bom eu acho que é isso o que você quer.

    Na célula A9 coloque a seguinte fórmula

    =SE(OU(E(A8>A2;A8<B2);E(A8>A3;A8<B3);E(A8>A4;A8<B4);E(A8>A5;A8<B5);E(A8>A6;A8<B6));COLOQUE AQUI A CONTA QUE VOCÊ QUER CASO ESTEJA DENTRO DA FAIXA;E AQUI FORA DA FAIXA)


    Veja se é isso mesmo.. que você quer

    Abraço
    ...
    • Sugerido como Resposta Alvinhoo terça-feira, 29 de setembro de 2009 11:58
    segunda-feira, 21 de setembro de 2009 16:47
  • Olá Toni_SP,
       Acho que entendi sua questão.
       Tem várias formas de soluciona-la. Gosto sempre das mais simples.
       Bom, apesar de nunca lembrado nestas horas, o PROCV pode também solucionar seu problema. Bem mais simples. 
       Faria assim:
    - mudaria a disposição das faixas...  

                   Colunas
    Linhas          A          B                       
    1            FAIXA    RETORNO
    2                 0        FAIXA 1
    3            1000        FAIXA 2        
    4            1246        FAIXA 3 (Atenção: usei o 1246, pois o 1245  ainda esta na faixa 1)
    5            2000        FAIXA 4
    6            2491        FAIXA 5
    7            3000        FAIXA 6
    8            3750        FAIXA 7
    9
    10
    11            quant(critério)  RETORNO
    12             1100                FAIXA 2


    Na coluna B12, colocaria a seguinte formula:
    =procv (a12;a2:b8;2;verdadeiro) ou
    =procv (a12;a2:b8;2;True) ou
    =procv (a12;a2:b8;2;1) 

     - onde:
      a12 - valor a ser procurado
      a2:b8 - intervalo de dados
      2 - coluna a retornar
      Verdadeiro, true ou 1 - procurar no intervalo é verdadeiro.

    Claro que coloquei as 'faixas' para ilustrar, coloque o retorno que melhor lhe ajudar.

    Obs: caso tenha valores negativos, substitua o zero da célula a2 por -1000 (ou numero menor).

    Espero ter ajudado.

    []'s


    Dan - BH/MG - Brasil - EMAIL REMOVED
    sexta-feira, 2 de outubro de 2009 03:14