none
WebService em Servidor RRS feed

  • Pergunta

  • Galera, tenho um webservice publicado no meu servidor. Ok

    Os testes que eu fiz com  webservice da minha máquina, passaram, ele funciona, traz dados do banco, tudo numa boa. Na minha máquina.

    Quando publico e jogo no iis do meu servidor .. os métodos não se comportam como na minha máquina local. Por exemplo um método eu preencho uma data e ele me traz uma lista de objetos. No webservice do servidor vejam a mensagem que me é apresentada:

    "System.NullReferenceException: A referência de objecto não foi definida como uma instância de um objecto. em DownloadCriteriosWS.ConsultaCriterios.getEntradas(String cpfCnpj, String dataInicial, String dataFinal) em: CAMINHO DO WEBSERVICE NA MINHA MAQUINA LOCAL(?) "

    Vejam como fiz a publicação do ws:

    Na minha máquina onde está meu projeto, fiz o publish do tipo FILE SYSTEM e escolhi um diretório;

    Copiei os arquivos deste diretório e joguei num diretório do meu servidor;

    Adicionei a aplicação no IIS, apontando para a raiz dos arquivos do meu projeto publicado;

    No IE digito localhost/diretorio arquivo asmx ;

    Clico nos métodos e insiro os parâmetros;

    Falta fazer alguma configuração diferente? Alguém sabe me dizer o que está errado?

    Valeu!

    quinta-feira, 24 de outubro de 2013 17:01

Respostas

  • Descobri ... Erro na minha string de conexão! 

    Na minha máquina o banco tinha uma senha .. esqueci de alterar a string de conexão com a senha do banco do servidor rs.


    • Marcado como Resposta Giovani Cr segunda-feira, 28 de outubro de 2013 16:57
    quinta-feira, 24 de outubro de 2013 18:20