none
Puxar valor correspondente RRS feed

  • Pergunta

  • Boa tarde

     Tenho a solução dessa questão usando formula (procv+indice). Agora precisava de uma solução por vba. Grato se puderem

    ajudar.

         https://www.sendspace.com/file/nb3c4d


    sábado, 2 de maio de 2015 19:27

Respostas

  • Em HA22:

    =PROCV(GZ22;GZ23:HA126;2;0)

    Em HB22:

    =PROCV(GZ22;GZ23:HB126;3;0)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta carlito_penna quarta-feira, 6 de maio de 2015 18:49
    segunda-feira, 4 de maio de 2015 12:25
    Moderador

Todas as Respostas

  • Em HA22:

    =PROCV(GZ22;GZ23:HA126;2;0)

    Em HB22:

    =PROCV(GZ22;GZ23:HB126;3;0)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta carlito_penna quarta-feira, 6 de maio de 2015 18:49
    segunda-feira, 4 de maio de 2015 12:25
    Moderador
  • Bom dia

    Grato pela resposta mas como havia dito no inicio do post, uso essa formula atualmente. Agora preciso dessa solução por VBA, uma vez que em GZ22 (vide plan) o código vai poder buscar outros valores como um comando, ao longo da lista. Se puder fazer uma macro, meus sinceros agradecimentos. 

    Em tempo:

    Os Procv´s das formulas, não retornam os valores esperados, alguma coisa saiu errado.


    segunda-feira, 4 de maio de 2015 14:24
  • Resolvido, grato
    quarta-feira, 6 de maio de 2015 18:49