none
Formula dias do mes RRS feed

  • Pergunta

  • Boa noite.

    Preciso de ajuda para uma formula com data, tenho que colocar em uma coluna os dias do mes, se eu fizer ex:

    Colocar a data na A1, e na A2 colocar =A1+1 e der sequencia para baixo até o dia 30 vai bem, mas se o mês tiver 31 ele já calcula o primeiro dia para o próximo mês, e eu preciso que ele só faça os dias do mês corrente.

    Fico no aguardo de uma ajuda.

    Atenciosamente


     

    sábado, 3 de agosto de 2013 02:37

Respostas

Todas as Respostas

  • Olá, boa noite!

    Considerando seu exemplo, em A2 experimente a fórmula:

    =SE(ÉNÚM(A1);   SE(MÊS(A1+1)=MÊS(A1);A1+1;"");   "")

    Um abraço.


    Filipe Magno

    sábado, 3 de agosto de 2013 03:26
  • Não tenho tantos conhecimentos de VB, mas posso te falar que a melhor

    forma de incrementar data é utilizando o tipo data da linguagem ou tecnologia que está utilizando.

    Por exemplo em .Net, você pode estar incrementando data a partir da propriedade new DateTime.Ticks.

    O tempo em .Net é dividido em 100 * 1 Nanosegundo.

    Se incrementar 1 em new DateTime.Now.Ticks estará pegando o tempo atual mais 100* 1 Nanosegundo.

    Procure alguma coisa parecida em VBA.

    Até a próxima!


    • Editado DiegoTi sábado, 3 de agosto de 2013 05:43 Correção
    sábado, 3 de agosto de 2013 05:40