none
Erro no servidor RRS feed

  • Pergunta

  • Boa tarde, publiquei um site em um diretório dentro do diretório de arquivos da web no servidor, e publiquei um projeto dentro desse diretório que criei, ele deveria exibir o projeto ao acessar o endereço fastautomacao.com.br/admin porém, me dá essa tela.


    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 17:38

Todas as Respostas

  • Nathalia boa tarde,

    A publicação foi concluída com sucesso ? O que dar a entender é que a master não foi publicada ou não está sendo localizada, via debug funciona corretamente ?

    Att.


    Guilherme Silva Cardoso

    quarta-feira, 16 de outubro de 2013 17:43
  • Nathalia boa tarde,

    A publicação foi concluída com sucesso ? O que dar a entender é que a master não foi publicada ou não está sendo localizada, via debug funciona corretamente ?

    Att.


    Guilherme Silva Cardoso

    Guilherme,

    Sim, foi concluída sim, e ele funciona normalmente via debug localmente. Eu já apaguei do servidor e subi pelo menos três vezes, continua com o mesmo erro.


    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 17:47
  • No IIS você criou a aplicação apontando para o diretório que está publicando ?

    Att.


    Guilherme Silva Cardoso

    quarta-feira, 16 de outubro de 2013 17:48
  • Eu não tive contato com o IIS Guilherme, assim que terminei a aplicação no Visual Studio, subi ela para o servidor, já havia feito isso com outros projetos e nenhum havia me dado problema, eu nunca precisei configurar nada no IIS, nem sei como fazer.

    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 17:50
  • Mas as outras aplicações estão em diretório dentro da raiz do servidor ? ( http://servidor/app1, app2, app3) ou já estão dentro de diretórios.


    Guilherme Silva Cardoso

    quarta-feira, 16 de outubro de 2013 17:54
  • Eu tive outros dois projetos antes desse em que eu precisaria usar um diretório dentro do diretório web pra apresentar um outro projeto, por exemplo o site mesmo em si do cliente tem seus arquivos publicados dentro do diretório web, que é onde ficam os arquivos visíveis na internet, dentro do diretório web eu criei um outro diretório chamado admin e publiquei o conteúdo de um outro projeto, um editor de conteúdo. Então quando acessa-se o dominio.com.br/admin deveria direcionar para o administrador de conteúdo porém me dá essa tela, sendo que outros sites que desenvolvi da mesma maneira não deram esse problema.


    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 17:59
  • Nathalia se você tiver acesso ao IIS tente criar uma aplicação baseada em diretório apontando para o diretório /admin e tente acessar.

    Att.


    Guilherme Silva Cardoso

    quarta-feira, 16 de outubro de 2013 18:06
  • Okay... não faço ideia de como se faz isso mas vou tentar...rs

    Obrigada.


    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 18:09
  • Espero que ajude,

    http://technet.microsoft.com/pt-br/library/cc772042(v=ws.10).aspx

    Se não der certo avise ae tento fazer junto contigo, OK ?

    Att.


    Guilherme Silva Cardoso

    quarta-feira, 16 de outubro de 2013 18:14
  • Ok... obrigada, qualquer coisa eu peço ajuda. Obrigada mesmo.

    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 18:25
  • Oi Nathalia,

    Tente substituir o til antes na propriedade MasterPageFiles por um ponto
    MasterPageFiles="./Gerenciador.Master"

    Funcionou pra mim uma vez, espero que funcione com você!

    Abraço

    quarta-feira, 16 de outubro de 2013 18:51
  • Oi Nathalia,

    Tente substituir o til antes na propriedade MasterPageFiles por um ponto
    MasterPageFiles="./Gerenciador.Master"

    Funcionou pra mim uma vez, espero que funcione com você!

    Abraço

    Olá Jonatan, eu fiz dessa forma e me retornou esse erro:


    Atenciosamente, Nathalia Santana

    quarta-feira, 16 de outubro de 2013 19:13