none
Mal funcionamento de botões RRS feed

  • Pergunta

  • Olá galera, boa tarde. Meu nome é Clóvis e trabalho como Suporte Técnico em uma empresa de desenvolvimento.

    Nós temos um problema com um de nossos programas que ninguém da empresa sabe como resolver. Em algumas máquinas de alguns clientes, na famosa tela de "Contrato e Termos de Uso" os botões de "Aceito" e "Não aceito" não funcionam. Você clica no "Aceito" e o programa não instala, você clica no "Não aceito" e o programa não encerra também. É como se o Javascript estivesse desativado...

    O programa é um executável, mas a tela de contrato é um HTML e os botões têm suas funções programadas em JavaScript. Eu sinceramente não faço ideia do que pode estar causando esse problema. Durante o suporte remoto que prestei aos usuários que apresentavam esse problema, eu desabilitei o anti-virus e firewall, verifiquei a execução do Javascript nos navegadores, desinstalei "add-ons" e toolbars, atualizei a versão do Internet Explorer, limpei os dados temporários, cookies e cache, registrei a DLL com o comando regsvr32 jscript.dll. Nada disso funcionou...

    O engraçado é que apenas 5 clientes reportaram esse problema, e não consegui identificar nada em comum entre eles que possa estar causando esse problema. Caso alguém tenha presenciado algo parecido, por favor compartilhe suas experiências aqui.

    Muito obrigado.

    quinta-feira, 29 de março de 2012 18:25

Todas as Respostas

  • Qual a versão do OS que está nas 5 maquinas?
    Qual a versão do IE das 5 maquinas?
    Qual o código executado no HTML?


    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    segunda-feira, 28 de maio de 2012 14:48