none
Enabled em textbox com problema RRS feed

  • Pergunta

  • Pessoal

          Tenho um form utilizando com tabcontrol e depois groupbox, e dentro destes controles, tenho alguns controles, dentre eles um textbox, onde utilizo alguns eventos como lostfocus, e leave e percebei quando clico em um button que tem a função de cancelar a operação, onde deve limpar todos os controles, e deixar alguns controles como enabled, só que em alguns casos o textbox fica na cor cinza como desabilitado, e outras mesmo desabilitado fica na cor branco, conforme arquivo em anexo, alguém passou por algo parecido ? E como devo proceder, para resolver este problema ?


    • Editado neibala quinta-feira, 10 de abril de 2014 16:15 Faltou o arquivo em anexo.
    quinta-feira, 10 de abril de 2014 16:12

Todas as Respostas

  • Olá,

    Já aconteceu isso comigo no inicio, verifique a Tab e o Groupbox, e deixe todos enabled = true, pois caso seu textbox estiver dentro de um Groupbox ou uma Tab que está desabilitada, ele e todos os outros controles dentro dela ficaram desabilitados também, mesmo que você altere a propriedade diretamente no controle.

    Abraço.


    "O verdadeiro sábio, é aquele que se coloca na posição de eterno aprendiz." Sócrates

    segunda-feira, 28 de abril de 2014 04:39
  • Paulo

       Só que o mais estranho, é que em nenhum momento estou desabilitando o tab ou o groupbox, pois caso contrario poderia realmente acontecer o que você comentou, você teria algum outra sugestão ?

    segunda-feira, 28 de abril de 2014 16:22
  • Olá,

    Ainda não sei, vou fazer uns testes e qualquer novidade eu posto aqui.

    Abraço.


    "O verdadeiro sábio, é aquele que se coloca na posição de eterno aprendiz." Sócrates

    segunda-feira, 28 de abril de 2014 17:35
  • cara não entendi o que vc quiz dizer, qual é o seu problema? algum textbox esta blqueado indevidamente, poste seu codigo para que eu possa analizar

    • Editado Jonnathanvb terça-feira, 29 de abril de 2014 13:49
    segunda-feira, 28 de abril de 2014 17:53
  • Jonnathan

        O problema é +/- assim, o textbox estão ficando desativado, só não sei por qual motivo, alguns textbox, fica na cor branco ao invez de fica na cor cinza, conforme pode ver no print da tela que enviei, sendo que o mesmo está enabled true, porque todos não ficaram na cor cinza, como é o padrão ?

    terça-feira, 29 de abril de 2014 02:48
  •  Paulo

        Agradeço a sua atenção, e qualquer novidade eu te aviso.

    terça-feira, 29 de abril de 2014 02:49
  • agora entendi,

    mais preciso de mais informação pra indentificar onde é o erro, preciso que vc post os codigos do eventos que estão nesses formulario e se todos os controles estão definidos como enabled = true, quando carrega, e vc so alterar depois a execução.

    sem os codigos não da pra dizer se você erro nos codigos ou é falha no visual studio

    terça-feira, 29 de abril de 2014 13:53
  • Jonnathan

        Quanto ao erro acredito que seja realmente de minha parte, quanto aos controles estarem todos como true, isto fiz os testes para certificar se existia algum faltando, agora existir algumas atualizações nos controles mesmo depois deles estarem com true, quanto ao envio do codigo é meio complicado, por isto perguntei se alguém já tivesse passado por ele problema, para identificar o que eu poderia estar fazendo algo errado.

    terça-feira, 29 de abril de 2014 14:12
  • ok!

    o problema provavelmente está nos codigos, não tem como ti ajudar a dizer onde vc errou sem saber como estar estruturado os codigos. tente ver passo a passo cada codigo no momento de execução coloque um breakpoint em cada evento, e boa sorte.

    terça-feira, 29 de abril de 2014 14:30
  • Jonnathan

      

        Agradeço a sua atenção desde já, mais a minha intensão era saber se alguém já tinha passado por este problema, pois sei que muitas vezes sem ver o código é complicado mesmo, mais valeu pela intensão.

        

    terça-feira, 29 de abril de 2014 14:55