locked
Posso ter um app para o Windows Phone 7 e para o 8. Com dois .XAP ? RRS feed

  • Pergunta

  • Gostaria de fazer o seguinte:

    Tenho um app feito em VS 2010. Que faz um app para windows phone 7. (Eu seu que ele funciona também no WP8)

    Mas quero fazer o mesmo app para windows phone 8 no VS 2012. POIS irei usar Recursos do windows phone 8 no app.

    Quero saber o seguinte: Tem como eu adicionar o .XAP que vou fazer no App do WP7, e a marketplace vai saber que quando a pessoa baixar do WP7 vai pegar o XAP do WP7   e do WP8   o XAP do WP8 ?

    Ou não tem como ? e eu tenho de criar um novo APP. Se for assim quais as dicas que vocês me dão para fazer app para as duas plataformas. Fazer com nomes "App WP7" e "App WP8"   ou outra ideia.

    quinta-feira, 29 de maio de 2014 16:04

Respostas

  • Bom dia Ewerton,

    Ve se esse tutorial te ajuda:

    http://blogs.windows.com/windows_phone/b/wpdev/archive/2013/01/15/app-submission-tips-for-windows-phone-7-and-windows-phone-8.aspx

    Abraço

    sexta-feira, 30 de maio de 2014 11:05

Todas as Respostas

  • Bom dia Ewerton,

    Ve se esse tutorial te ajuda:

    http://blogs.windows.com/windows_phone/b/wpdev/archive/2013/01/15/app-submission-tips-for-windows-phone-7-and-windows-phone-8.aspx

    Abraço

    sexta-feira, 30 de maio de 2014 11:05
  • Beleza    to fazendo aqui já, Tem alguma outra forma de tirar print do celular na qualidade 720 p ?    

    Pois  480x800  tiro apertando os botoes laterais do lumia.

    Só uma pergunta adicional, os meus emuladores não funcionam  de jeito nenhum, Acho que é algo do Hyper-V!

    Meu notebook é um Dell Inspiron 14 tinha windows 7 funcionava agora não funciona de jeito nenhum, você já passou por isto, pesquisei bastante na net, mas nada do que falam realmente funcionou, o máximo que eu consegui foi abri o emulador sem erros, MAS sem ele poder usar internet.



    sábado, 31 de maio de 2014 01:38
  • Beleza    to fazendo aqui já, Tem alguma outra forma de tirar print do celular na qualidade 720 p ?    

    Pois  480x800  tiro apertando os botoes laterais do lumia.

    Só uma pergunta adicional, os meus emuladores não funcionam  de jeito nenhum, Acho que é algo do Hyper-V!

    Meu notebook é um Dell Inspiron 14 tinha windows 7 funcionava agora não funciona de jeito nenhum, você já passou por isto, pesquisei bastante na net, mas nada do que falam realmente funcionou, o máximo que eu consegui foi abri o emulador sem erros, MAS sem ele poder usar internet.



    Bom dia Ewerton,

    Não entendi direito seu problema referente ao Win 7, ele nem abre mais?

    Em relação ao print screen, eles são automáticos não sendo possível alterar a qualidade, você pode baixar alguns programas gratuito no seu pc e fazer a conversão para uma qualidade superior, ja fiz isso com vídeos mas nunca com fotos, mas não acho que seja diferente

    Em relação ao emulador você usa qual server?

    Abraço

    segunda-feira, 2 de junho de 2014 11:36
  • Ficou meio vago mesmo minha pergunta!

    Vou explicar melhor:

    Tinha um Win 7 e tive que migrar para o Win 8 para desenvolver para WP8 e Win 8.

    Instalei tudo certo VS 2012 (para WP8) e VS 2013 (para Windos 8).

    Só que quando fui usar o emulador no VS 2013 deu erro não emula, dá erros. (Mas ai eu tentei no device que é o próprio windows 8, e funcionou, até ai menos mal que dá para usar o próprio windows 8 como device).

    Ai pensei por enquanto vou desenvolver para windows phone 8 mesmo então tá legal.

    O problema foi quando fui usar o emulador no VS 2012 deu erro também! Ai ficou meio doidão rsrs. Procurei na net tudo quando é jeito e nada. Ai pensei vou formatar o PC (mas nem formatei pois avia acabado de formatar o PC com o New Windows 8).  ... Passou um tempinho eu ainda estava programando no Windows 8 -> No VS 2012 -> Para windows phone 7 !&?!?!?!   palhaçada pensei. 

    Agora só posso programar para WP7, pois Para ENVIAR um app para windows phone 8 preciso de PRINT da minha app na qualidade 720 p.  Só consigo dá manutenção nos meus apps que fiz para WP7.

    O Problema é que não aconteceu só comigo vi várias pessoas com o mesmo problema.

    Pelo que vi este problema está relacionado com o Hyper-V. Não dá nem para instalar o VWare por causa do Hyper-V    para que o Microsft foi mexer com isto hein !!!!  Foi colocar coisa de Server no Windows 8 bagunçou o trem tudo. E também um negoço de criar PONTE nas conexões que rede que dá só problema quando vou usar o emulador ele tenta criar uma ponte lá e bagunça minha net todinha.

    É isto ai ficou meio longa    Mas expliquei bem. Grato desde já pela ajuda.

    segunda-feira, 2 de junho de 2014 18:57
  • Seu windows 8 é PRO ou Single Language?

    Eu tive problemas em usar o emulador no windows 8 por causa de alguns recursos que só estão disponíveis no windows 8 PRO, enquanto o meu é a versão Single Language. Quando eu desenvolvia pra windows phone 7.x o emulador funcionava normalmente.

    segunda-feira, 2 de junho de 2014 19:10
  • O erro que ta dando é esse?

    The windows phone emulator wasn´t able to create the virtual machine!!! 

    Something happened while creating a switch: Xde couldn´t as IPv4 adress for the host machine.

    O seu hardware suporta virtualização? Nesse link tem os requisitos necessários para rodar o Windows phone 8 emulator: http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff626524(v=vs.105).aspx

    Você habilitou o suporte a virtualização na BIOS?

    Caso você tenha qualquer outro sistema de virtualização (VirtualBox, VPN, etc) remova os mesmos pois eles podem causar esse erro.

    Você esta com um S.O. x64? É necessário utilizar o Sistema Operacional de 64bits.

    A sua versão do S.O é a PRO ou superior?

    Você tentou limpar os 'switches' existentes no Hper-v Manager e criar um novo:(XdeCleanup.exe is located in C:Program Files (x86)Microsoft XDE8.0)

    Att,


    segunda-feira, 2 de junho de 2014 19:12
  • Eu tenho o Window 8 PRO.

    No windows 7 desenvolvi normal também.

    segunda-feira, 2 de junho de 2014 19:46
  • Ricardo   já vi dois erros diferentes   Mas um e mais comum é este ai mesmo.

    Sobre se meu hardware suporta virtualização ? Vou ler o link que você me passou e já respondo. Mas seria palhaçada, Se um Dell Inspiron 14  4 GB de RAM  i3  não servir para programar para o Windows phone 8.

    Vou ver isto também!

    Não tenho outro programa de virtualização (cite o Vware pois tentei instalar ele!).

    Sim meu sistema é x64.

    Versão PRO.

    Vou isto também, assim que chegar em casa.

    Valeu por enquanto.

    segunda-feira, 2 de junho de 2014 19:53
  • ok fico no aguardo, tenta limpar o switch do hype-v também. Acho difícil também esse dell não suportar mas é sempre bom eliminar todos os possíveis problemas.

    Att,


    segunda-feira, 2 de junho de 2014 20:21
  • as duas primeiras coisas que fiquei para ver:

    na bios virtualization está ENABLED

    e pelo que eu vi meu note suporta virtualização.

    a única coisa que não fiz foi limpar o switch.

    você acha que se tiver de funcionar eu posso formatar e depois atualizar o Windows e instalar so o VS 2012 ? Você acha que vai funcionar pois vou formatar para testar, pq não é por nada não mas o programa tem que funcionar por conta própria, é instalar e usar.

    terça-feira, 3 de junho de 2014 14:47
  • Fala Ewerton,

    Ja que você tem o Hyper-v eu aconselharia fazer uma VM e nela instalar o Windows com VS2012 que ai se funcionar tudo certinho pode sim formatar o Dell.

    Att,

    terça-feira, 3 de junho de 2014 17:59
  • instalei o windows 8.1

    e instalei os updates      e depois instalei VS 2012.

    E deu dois errros:

    erro no vs 2012

     

    e na hora da instalação   e na hora de rodar da este aqui

    erro do emulador

    MAS to instalando o update 4  do VS 2012       vi alguns posts   que diz que RESOLVE!

    vamos ver       depois respondo aqui para ver se funcionou!

    quinta-feira, 5 de junho de 2014 21:51
  • Consegui Rodar o emulador. 

    MAS tem um problema, este emulador está doidão ele pega o IP e Mascara de sub-rede   Mas não pega o Gateway!

    Resumindo CONSIGO rodar o Emulador. MAS fico sem internet no notebook e no Emulador. Ou seja, NÃO consigo ter internet no meu Emulador. Quase inútil para o que eu estava pensando em desenvolver.

    Veja as imagens de meu One Driver

    Veja as imagens do OneDriver.

    Tirei alguns print´s   para mostrar a situação. 

    Alguém poderia me ajudar. E Ricardo Barbosa acho que testei tudo que você me passou. A limpeza lá nem preciso falar pois acabei de instalar o Windows e o VS 2012 for WP.

    Grato desde já pela ajuda.

    quinta-feira, 5 de junho de 2014 23:31