none
IIS 7.0 + Windows Vista Business RRS feed

  • Pergunta

  • Pessoal,

    Por favor, trabalho com o Vista Business + o IIS 7.0. Quando realizo o invoke pelo browser(IE 7.0) de qualquer método e qualquer web service, retorna a mensagem abaixo:
    System.InvalidOperationException: Client found response content type of '', but expected 'text/xml'.
    The request failed with an empty response.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at FlexHelpAppDataWS.AppData.ExecuteDatasetByText(String dbKey, String sqlText, Object[] sqlValues) in c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\OAEWS\aadaa57f\587788e0\App_WebReferences.d9rt2a6k.0.cs:line 487
       at Cadastro.ListarSubsecoes() in c:\Users\Bruno\Desktop\VSS\MinhaPasta\OEASP\App_Code\Cadastro.cs:line 35
    
    a linha 35 a que se refere é: appData.ExecuteStoredProc(oabsp.DBKeys.Controladoria, ref dsRetorno, "dbo.uspListaAnosFiscais", ref sqlValues);

    porém para qualquer método ele reclama nesta linha exatamente.

    Acredito ser problema com o IIS 7.0, fiz a instalação e deixei as opções default habilitadas, não acrescentei nem retirei nada na instalação, já tentei de tudo mas nada ainda.

    P.S. os demais colegas aqui do trabalho utilizando o XP + IIS 6.0 conseguem rodar os metódos sem problema.

    Agradeço a colaboração.

    Bruno

    sexta-feira, 3 de julho de 2009 12:06

Respostas