locked
Index + Corresp + "codigo nao existe" RRS feed

  • Pergunta

  • Srs

    Apanhando na linha abaixo.... help, please....

    Se o código digitado na celula D9 nao existir, entao mostre a mensagem "Código nao existe...",

    mas há um erro na minha linha abaixo, por favor...

    =SE(ÉERROS(D9);"Código não existe";ÍNDICE(Servicos!C2014:U2035;CORRESP(D9;Servicos!L2014:L2035;0);3))

    Grato pela atencao

     

    terça-feira, 8 de março de 2011 23:36

Todas as Respostas

  • Jonas, A célula D9 pode conter um código qualquer que não dá erro porém não está presente na faixal l2014:l2035

     

    Se vc usa o excel2007 ou superior vc pode tentar assim

    =seerro( ÍNDICE(Servicos!C2014:U2035;CORRESP(D9;Servicos!L2014:L2035;0);3) ; "Código Não Existe" ) 



    João Eurico Consultor Manguetown - Brazil
    • Sugerido como Resposta jes_kp quinta-feira, 10 de março de 2011 17:59
    quarta-feira, 9 de março de 2011 06:25
  • John

    Fantastic !!!

    Thank you

    quarta-feira, 9 de março de 2011 11:58