none
publicando um webservice RRS feed

  • Pergunta

  • Fiz o meu primeiro web service nele tenho uma classe para incluir registros e outras para consulta, na minha maquina funciona perfeito, fiz esse webservice no vs2010 na framework 3.5 e estou publicando no iis 7, no vs2010 fui no projeto e executei o publish como faço para todas as aplicações que eu faço, sendo que no webservice não esta dando certo.

    Preciso criar um projeto web dentro do projeto do webservice ?


    Junior

    segunda-feira, 4 de fevereiro de 2013 16:58

Todas as Respostas

  • Retorna algum erro ao tentar publicar ?

    Você tem o caminho público em seu servidor na qual está o WebService. Assegure-se que o arquivo .ASMX esteja nesse caminho, e as DLL do webservice, na pasta bin.


    Se a sugestão resolver o problema, favor marcar como Resposta.

    segunda-feira, 4 de fevereiro de 2013 22:10
  • Junior o processo é o mesmo, eu normalmente crio um outro diretótio para o services

    Não esqueça de usar o componente </> na barra para posta seu código. Microsoft MCPD,MCTS,MCC

    terça-feira, 5 de fevereiro de 2013 10:54
  • Seilor eu acho que o problema está na framework eu vi uma solução onde tem que trocar a sequencia da framework de 4 para 4 classic no iis, mais nesse servidor tenho projetos executando com a framework 4, não quero mexer e dar problemas nos projetos que já estão em execução.

    Estou refazendo o webservice pelo wcf, estou tendo algumas dificuldades, mais qualquer coisa posto aqui.


    Junior

    terça-feira, 5 de fevereiro de 2013 11:22
  • Não precisa vc cria um somente appPool  para seu service

    Não esqueça de usar o componente </> na barra para posta seu código. Microsoft MCPD,MCTS,MCC


    terça-feira, 5 de fevereiro de 2013 12:50
  • Seilor fiz isso e não deu certo, mais publiquei em outro servidor que tenho onde nele tenho sistemas rodando na framework 3.5 e o IIS é 6.5 e rodou normal.

    Junior

    terça-feira, 5 de fevereiro de 2013 13:19
  • Cara vc tem todos os frameworks instalado no server? veja suas configs no webconfig tb

    Não esqueça de usar o componente </> na barra para posta seu código. Microsoft MCPD,MCTS,MCC

    quarta-feira, 6 de fevereiro de 2013 10:33