none
Desespero RRS feed

  • Pergunta

  • Ola senhores do Conselho, boa noite.

    Cenário: Precisei formatar a maquina (windows 7 64 bits) e reinstalei o sistema operacional versao 32 bits. Reinstalei o VS 2010 e os relatórios Crystal aparecem dessa forma:

    Daí, formatei a maquina, voltei aos 64 bits e nada mudou...

    Alguem sabe o que aconteceu?

    Instalei: VS 2010, CRforVS_redist_install_64bit_13_0_12...

    Obrigado por qualquer ajuda... (terei de fazer 17 relatórios novamente?)


    Luiz Melo

    domingo, 11 de janeiro de 2015 22:08

Respostas

  • Pois eh... nao consigo criar um itemk de relatorio... aparece isso:

    Mas, instalei o CRforVS_redist_install_64bit_13_0_12...

    O que precisa mais? Se ele nao vem com o VS2010 e a gente instala... não deveria funcionar?

    O projeto, antes da formatação funcionava perfeitamente. Como saber se ele está instalado no VS?

    Se tente reinstalar o CRforVS_redist_install_64bit_13_0_12 ele me da a opção de reparar ou remover...Isso não é indicativo de que está instalado?

    Agradeço de antemão qualquer ajuda.

    Luiz Melo


    Luiz Melo

    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 09:19
  • Olá.

    Voce precisa instalar um setup do crystal 32 bits for vs.

    Eu tenho o setup  "CRforVS_13_0_2" por exemplo, que é a versão 13.0.2.

    se voce conseguir encontrar no site outra versão, acho que vai funcionar também.

    Obs: você precisa instalar o setup.exe (não  arquivo.msi)

    espero que te ajude.

    link da versao 13.0.2.  http://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_13_0_2.exe


    • Editado Jose Geraldo segunda-feira, 12 de janeiro de 2015 12:46 acrescentar o link
    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 09:28
  • Luiz,

    O crystal pode até estar instalado, mas não foi referenciado no vs2010, veja a imagem abaixo.

    verifique este link acredito que ira lhe ajudar.

    http://www.andrealveslima.com.br/blog/index.php/2014/09/10/suporte-ao-crystal-reports-visual-studio-2013/

    Att, Wsti.

    Se for util marque!!

    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 11:28

Todas as Respostas

  • Luiz vc add o crystal na toolbox do vs 2010 ?

    ja verificou o dataset ?

    • Editado Wsti domingo, 11 de janeiro de 2015 22:45
    domingo, 11 de janeiro de 2015 22:42
  • Você esta com o crystal reports instalado mesmo?, consegue fazer um projeto usando Crystal Reports?

    Quando vai abrir um arquivo RPT ele chama o Crystal Reports para renderizar mais pelo que vejo o crystal ou não esta instalado corretamente ou não esta integrado ao visual studio, faz o teste acima que mencionei criando um usando o Crystal

    domingo, 11 de janeiro de 2015 22:44
  • Pois eh... nao consigo criar um itemk de relatorio... aparece isso:

    Mas, instalei o CRforVS_redist_install_64bit_13_0_12...

    O que precisa mais? Se ele nao vem com o VS2010 e a gente instala... não deveria funcionar?

    O projeto, antes da formatação funcionava perfeitamente. Como saber se ele está instalado no VS?

    Se tente reinstalar o CRforVS_redist_install_64bit_13_0_12 ele me da a opção de reparar ou remover...Isso não é indicativo de que está instalado?

    Agradeço de antemão qualquer ajuda.

    Luiz Melo


    Luiz Melo

    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 09:19
  • Como de faz esse add do crystal na toolbox do vs 2010?

    Obrigado de antemão...


    Luiz Melo

    segunda-feira, 12 de janeiro de 2015 09:20
  • Olá.

    Voce precisa instalar um setup do crystal 32 bits for vs.

    Eu tenho o setup  "CRforVS_13_0_2" por exemplo, que é a versão 13.0.2.

    se voce conseguir encontrar no site outra versão, acho que vai funcionar também.

    Obs: você precisa instalar o setup.exe (não  arquivo.msi)

    espero que te ajude.

    link da versao 13.0.2.  http://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_13_0_2.exe


    • Editado Jose Geraldo segunda-feira, 12 de janeiro de 2015 12:46 acrescentar o link
    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 09:28
  • Luiz,

    O crystal pode até estar instalado, mas não foi referenciado no vs2010, veja a imagem abaixo.

    verifique este link acredito que ira lhe ajudar.

    http://www.andrealveslima.com.br/blog/index.php/2014/09/10/suporte-ao-crystal-reports-visual-studio-2013/

    Att, Wsti.

    Se for util marque!!

    • Marcado como Resposta Luiz Melo segunda-feira, 12 de janeiro de 2015 13:25
    segunda-feira, 12 de janeiro de 2015 11:28
  • Vamos lá, o redist é somente para distribuição de sua aplicação ou seja onde você for distribuir seu aplicativo deve instala-lo, para o desenvolvimento tem que instalar pelo Setup do Crystal Reports aqui (de preferencia com o visual studio fechado)
    segunda-feira, 12 de janeiro de 2015 14:05