none
FUNÇÃO PROCV RRS feed

  • Pergunta

  • Elaborei uma planilha excel, onde tenho uma planilha como base de dados e na planilha de pedidos usando a função PROCV. Porém, na primeira coluna da planilha de produtos (quero retornar UNIDADE e valor unitário), quando a descrição do produto possui acima de 255 caracteres, a função não retorna resultado para as colunas de UNIDADE e PREÇO UNITÁRIO. Como desfazer essa restrição de limites de caracteres do produto, que nesse caso é o VALOR_PROCURADO da fórmula.
    domingo, 22 de julho de 2018 21:51

Todas as Respostas

  • Olá Idalmar!

    A função PROCV apresentará esta limitação ao fazer esta busca com o valor_procurado superior à 255 caracteres. A função CORRESP apresentará o mesmo comportamento.

    Minha sugestão inicial é você rever a organização dos seus dados. Eu nunca ví um código de produto com mais de 255 caracteres. Eu acredito que você deve extrair este cadastro que você com uma série de informações juntas e ficam na mesma célula. Neste caso, tente extrair somente o código para uma coluna específica.

    Se não tiver como alterar a estrutura da sua pasta de trabalho, então você pode recorrer a fórmulas matriciais que não terá essa limitação de 255 dígitos, porém dependendo do tamanho da sua base, poderá tornar o arquivo lento, pois as fórmulas exigem mais processamento.

    Por exemplo, supondo que você deseja trazer o valor da coluna B e a busca será feita com base no texto da coluna A:

    =ÍNDICE($B$1:$B$100;MÁXIMO(SE($A$1:$A$100="VALOR_PROCURADO";LIN($A$1:$A$100);"")))

    A fórmula deve ser inserida com CTRL+SHIFT+ENTER.


    Rafael Kamimura - http://excelmaniacos.com


    segunda-feira, 23 de julho de 2018 14:43