none
Perda de permissão RRS feed

  • Pergunta

  • Pessoal bom dia,

    Trabalho com Projeto 2013 com sharepoint..

    No sharepoint existe um portal especifico para a Central de Projetos, e do nada sumiram todas as permissões.. neim o Farm tem acesso a pagina..

    Alguem consegue me da uma luz?

    obrigado!

    sexta-feira, 9 de maio de 2014 11:38

Respostas

  • Interessante este caso.

    O que posso recomendar, senão já resolveste claro. É analisar os ULS com a categoria de segurança - security. Se estiver também habilitado o log de auditoria será mais fácil de tentar achar o que ocorreu.

    Mas o velho troubleshooting também é muito válido, imaginando que não foi alguem e sim algo que parou de funcionar.

    Não esquecendo claro que no EPM 2010 eram 4 bases e devem ser feito um "merge" para 1 só e fazer o provisionamento corretamente. Mas como você falou que ficou funcionando 1 mês e parou. 

    a) Olhe o Event Viewer do Windows e veja se não tem erros aparecendo

    b) Parece muito comum um erro de conta de serviço com problema ou aplicações de regras de GPO que acabam influenciando na aplicação.

    c) Olhe também a Central de Administração - Gerenciamento de Aplicação - Visualizar Coleção de Site e veja se lá tem o /PWA. Se tiver ninguem deletou. Ou seja, é outro problema.

    d) Você não atualizou para SP1 né?

    Enfim, veja estes pontos e retorne.

    Bruno Velaz


    Bruno Velaz - http://brunovelaz.spaces.live.com |*| CanalSharepoint.com.br\brunovelaz

    • Marcado como Resposta Mbonzanini quinta-feira, 7 de agosto de 2014 18:35
    segunda-feira, 12 de maio de 2014 23:11

Todas as Respostas

  • Olá Mbonzanini, 

    Você fez algum upgrade de ambiente? Exemplo migrou da versão 2010 para a 2013?

    Se sim, saiba que as antigas web applications do SharePoint 2010 usavam o modo de autenticação clássico do Windows. E isso também precisa ser atualizado no seu atual ambiente. Este script PowerShell pode ser usado para determinar que a web application atual utilize a a autenticação baseada em declarações:

    $ Web = Get-SPWebApplication "URL> para application>" 
    $ Web.UseClaimsAuthentication

    Depois eu corri através dos passos para migrar de de modo clássico para autenticação baseada em declarações: 

    http://technet.microsoft.com/en-us/library/gg251985.aspx

    Espero ter ajudado.


    Obrigado por contactar o fórum Microsoft Technet!

    sexta-feira, 9 de maio de 2014 12:18
    Moderador
  • Olá boa tarde Hezequias..

    Sim, foi feito o upgrade do SharePoint 2010 para 2013, porem funcionava normalmente..

    Do nada a pagina do PWA parou de "funcionar", todos perderam a permissão, inclusive o admin Farm..

    Depois do upgrade funcionou normalmente por 1 mes..

    Mesmo que alguem tenha tirado todas as permissões, ainda é possivel arruma-los sem ter que voltar o restore?

    att,

    segunda-feira, 12 de maio de 2014 17:36
  • Interessante este caso.

    O que posso recomendar, senão já resolveste claro. É analisar os ULS com a categoria de segurança - security. Se estiver também habilitado o log de auditoria será mais fácil de tentar achar o que ocorreu.

    Mas o velho troubleshooting também é muito válido, imaginando que não foi alguem e sim algo que parou de funcionar.

    Não esquecendo claro que no EPM 2010 eram 4 bases e devem ser feito um "merge" para 1 só e fazer o provisionamento corretamente. Mas como você falou que ficou funcionando 1 mês e parou. 

    a) Olhe o Event Viewer do Windows e veja se não tem erros aparecendo

    b) Parece muito comum um erro de conta de serviço com problema ou aplicações de regras de GPO que acabam influenciando na aplicação.

    c) Olhe também a Central de Administração - Gerenciamento de Aplicação - Visualizar Coleção de Site e veja se lá tem o /PWA. Se tiver ninguem deletou. Ou seja, é outro problema.

    d) Você não atualizou para SP1 né?

    Enfim, veja estes pontos e retorne.

    Bruno Velaz


    Bruno Velaz - http://brunovelaz.spaces.live.com |*| CanalSharepoint.com.br\brunovelaz

    • Marcado como Resposta Mbonzanini quinta-feira, 7 de agosto de 2014 18:35
    segunda-feira, 12 de maio de 2014 23:11