none
Instabilidade de conexão RRS feed

  • Pergunta

  • Olá pessoal.

    Estou com uma GRANDE dificuldade com meus bancos de dados SQL Azure já tem uns 20~30 dias...

    Com muita (MUITA MESMO) frequência erros de "Timeout", erros de "Conexão física não pode ser utilizada", enfim... uma série de erros relacionados a hand-shake e rede vem atormentando a minha vida.

    E não é exclusividade dos meus aplicativos.

    A maior parte das vezes esses erros ocorrem no SSMS! Ao tentar mapear tabelas com o EF...

    Já tentei trocar meu servidor de data center, mudar de Web para Business... Mas mesmo assim os erros não param.

    Alguém tem alguma idéia de como posso resolver isso?


    terça-feira, 29 de abril de 2014 20:30

Respostas

  • Giovani, bom dia!

    Digamos que eu "consegui" resolver, mas a solução sugerida acima não resolveu os problemas.

    Mas eu detectei uma falha na configuração dos servidores de DNS do provedor, para minha região... Após vários resets sem sucesso no modem da empresa, entrei em contato com a central e fizeram um reset geral lá... E a coisa começou a funcionar...

    Ainda acontece, mas é raro...

    Grato pela ajuda!

    • Marcado como Resposta Giovani Cr segunda-feira, 9 de junho de 2014 19:23
    segunda-feira, 19 de maio de 2014 11:55

Todas as Respostas

  • Estou utilizando Sql Database sem problemas. Pelo cenário descrito imagino que o problema é outro.

    Sugiro o seguinte:

    Via SQL Server Profile, monitore o banco e capture algumas queries criadas via Entity Framework. Depois execute de fora do Azure as mesmas queries. O problema pode ser queries mal formatadas / Lazy Loading.

    Links utéis:

    Anti-Patterns EntityFramework

    Select n+1 (Entity Framework)


    Thiago Custodio | Software Engineer
    Blog
    Twitter
    Faça parte da Comunidade Windows Azure Brasil no Facebook

    quarta-feira, 30 de abril de 2014 12:29
  • Obrigado pela dica... vou verificar e logo atualizo a Thread...

    Mas o curioso é que... por exemplo... DA EMPRESA isso acontece com frequência... EM CASA... não acontece tanto...

    É zuado...

    quarta-feira, 30 de abril de 2014 13:00
  • Bom dia Jefferson,

    Conseguiu resolver?

    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 5 de maio de 2014 19:48
  • Giovani, bom dia!

    Digamos que eu "consegui" resolver, mas a solução sugerida acima não resolveu os problemas.

    Mas eu detectei uma falha na configuração dos servidores de DNS do provedor, para minha região... Após vários resets sem sucesso no modem da empresa, entrei em contato com a central e fizeram um reset geral lá... E a coisa começou a funcionar...

    Ainda acontece, mas é raro...

    Grato pela ajuda!

    • Marcado como Resposta Giovani Cr segunda-feira, 9 de junho de 2014 19:23
    segunda-feira, 19 de maio de 2014 11:55