none
O servidor Web está configurado para não listar o conteúdo deste diretório. RRS feed

  • Pergunta

  • Pessoal,

    Boa Tarde a todos,

    Estou com um problema para rodar o WCF.

    Ele exibe a seguinte mensagem:

    O servidor Web está configurado para não listar o conteúdo deste diretório

    e quando eu defino o meu arquivo .svc para set as Start Page, o programa não compila.

    Alguém já passou por isso ?

     

    Desde já agradeço a atenção de todos

     


    Jacqueline Sabino
    segunda-feira, 7 de novembro de 2011 18:47

Respostas

  • Oi Jaqueline

    O seu serviço precisa expor de alguma forma seus metadados para que os consumidores possam criar clientes e chamar o seu serviço.

    Existem basicamente duas formas.

    Via Behaviours expondo via GET o wsdl

    ou criando um mex (meta data exchange) endpoint.

    http://msdn.microsoft.com/en-us/library/system.servicemodel.description.servicemetadatabehavior.aspx

    Parece que tem um segundo erro ai de autenticação. Tente expor os metadados primeiros e criar um proxy com o svcutil ou no visual studio add service reference.

     


    Alberto Cardoso
    • Marcado como Resposta Jack Sabino terça-feira, 8 de novembro de 2011 11:10
    terça-feira, 8 de novembro de 2011 01:27

Todas as Respostas

  • Pessoal,

    Eu consegui resolver o problema em partes,

    agora está aparecendo o seguinte erro:

    Error: Cannot obtain Metadata from http://localhost/ If this is a Windows (R) Communication Foundation service to which you have access, please check that you have enabled metadata publishing at the specified address.  For help enabling metadata publishing, please refer to the MSDN documentation at http://go.microsoft.com/fwlink/?LinkId=65455.WS-Metadata Exchange Error    URI: http://localhost/    Metadata contains a reference that cannot be resolved: 'http://localhost/Orizon.wsBPO_APOIO/BPO_APOIO.svc'.    The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'Negotiate,NTLM'.    The remote server returned an error: (401) Unauthorized.HTTP GET Error    URI: http://localhost/    There was an error downloading 'http://localhost/ The request failed with the error message:--<html>    <head>        <title>As configura‡äes de seguran‡a para este servi‡o exigem a Autentica‡Æo 'Anonymous', mas ela nÆo est  ativada para o aplicativo IIS que hospeda esse servi‡o.</title>        <style>   

    Alguem sabe como resolver isso?     


    Jacqueline Sabino
    segunda-feira, 7 de novembro de 2011 19:42
  • Oi Jaqueline

    O seu serviço precisa expor de alguma forma seus metadados para que os consumidores possam criar clientes e chamar o seu serviço.

    Existem basicamente duas formas.

    Via Behaviours expondo via GET o wsdl

    ou criando um mex (meta data exchange) endpoint.

    http://msdn.microsoft.com/en-us/library/system.servicemodel.description.servicemetadatabehavior.aspx

    Parece que tem um segundo erro ai de autenticação. Tente expor os metadados primeiros e criar um proxy com o svcutil ou no visual studio add service reference.

     


    Alberto Cardoso
    • Marcado como Resposta Jack Sabino terça-feira, 8 de novembro de 2011 11:10
    terça-feira, 8 de novembro de 2011 01:27
  • Pessoal,

    O Problema estava relacionada as configurações do Usuário Anonymous,

    após permitir acesso pro Usuário Anonymous deu certo.

     

    Att


    Jacqueline Sabino
    terça-feira, 8 de novembro de 2011 11:10