none
Barra de título e botões desaparecem - após atualização app delphi desktop RRS feed

  • Pergunta

  • Olá, desenvolvemos sistema ERP em delphi e recentemente notamos um problema em 2 computadores de clientes distintos após atualização rotineira do sistema. 

    A renderização de botões e das barras de títulos das janelas fica branca ou invisível, mas ainda permanecem ali se passamos o mouse sobre os botões.

    Já testamos criando uma nova app vazia, em modo de compatibilidade, com temas visuais desabilitados, em modo administrador, modo 256 cores, mas continua o problema...

    No entanto, se carregamos um ponto de restauração do windows de um dia atrás, o problema é corrigido, mesmo com a app atualizada. Porém 1 dia depois, volta o problema, mesmo com os updates do windows desativados. A única modificação que aparece nesse ponto de restauração em comum nos 2 clientes é no snap-in mstsc, conforme abaixo:

    http://oi59.tinypic.com/au770k.jpg

    Há como desativar essa atualização obscura do mstsc? Como conseguimos auditar o que realmente está sendo corrigido com a restauração do windows? 

    Parece se tratar, por outro lado, de um 'dll hell', pois estranhamente o windows adotou o ícone da nossa app, conforme abaixo:

    http://oi60.tinypic.com/29xf61i.jpg

    Vocês têm alguma ideia de solução de contorno onde possamos isolar a app dentro do próprio windows? Ou seja lá outra coisa que possa ser feita (além de remediar formatando)...

    Obrigado!!

    Lucas

    sexta-feira, 10 de julho de 2015 13:27

Respostas

  •  Bom dia, rodamos o aplicativo InstallWatchPro para auditar a restauração do windows porém não foi conclusivo.

    Realizamos alguns outros testes e o que solucionou em definitivo o problema foi a criação de um usuário adicional no windows. Nem sequer precisamos acessar o usuário e o sistema já está sendo renderizado normalmente.

    • Marcado como Resposta SoftSul segunda-feira, 20 de julho de 2015 11:15
    segunda-feira, 20 de julho de 2015 11:15

Todas as Respostas

  • Ambos computadores tem windows seven 64 bits.
    sexta-feira, 10 de julho de 2015 13:34
  •  Bom dia, rodamos o aplicativo InstallWatchPro para auditar a restauração do windows porém não foi conclusivo.

    Realizamos alguns outros testes e o que solucionou em definitivo o problema foi a criação de um usuário adicional no windows. Nem sequer precisamos acessar o usuário e o sistema já está sendo renderizado normalmente.

    • Marcado como Resposta SoftSul segunda-feira, 20 de julho de 2015 11:15
    segunda-feira, 20 de julho de 2015 11:15
  • Bom dia, estou passando pelo mesmo problema, formatamos a maquina e instalei o win64 bits e começou o problema, formatamos novamente e instalei o win32, só que o problema continua...Estou achando que é problema de memória, estou fazendo testes mais nada resolvido ainda.

    Grato

    Junior Clemente

    sexta-feira, 11 de setembro de 2015 14:12