none
Utilizar referência de célula em critério de SOMASES RRS feed

  • Pergunta

  • Tenho uma planilha com lançamentos em uma conta-corrente e preciso acumular pelo "motivo" (origem, ou destino) da movimentação, e pelo mês da movimentação.

    1º eu filtro por uma identificação de "motivo" do lançamento,

    2º eu preciso filtrar para identificar os lançamentos efetuados entre o dia 1º e o último dia do mês, isto é, fazer uma interpolação entre o início e o fim do mês e acumular na coluna correta (1 coluna por mês) as somas mensais da movimentação do tipo de 1º filtro.

    =SOMASES(ExtrAcumClass!$H$4:$H$503;ExtrAcumClass!$B$4:$B$503;$A7;ExtrAcumClass!$C$4:$C$503;">E1";ExtrAcumClass!$C$4:$C$503;"<E2")

    ExtrAcumClass!$H$4:$H$503 => valores a serem somados nas condições especificadas

    ExtrAcumClass!$B$4:$B$503 => "motivo" da movimentação do valor (de onde veio)

    $A7 => célula que contém o valor do filtro de "motivo"

    ExtrAcumClass!$C$4:$C$503 = Datas dos lançamentos a serem pesquisadas como 2 condições, início e término da pesquisa.

    Aqui a coisa engancha:

    E1 é o dia de início para comparação pois só quero os lançamentos entre o dia 1º e o último dia do mês

    E2 é o dia de término para comparação pois só quero os lançamentos entre o dia 1º e o último dia do mês

    1. Se coloco no critério ">E1" ele não analisa o critério, pois o conteúdo da célula não é essa constante

    2. Se coloco apenas a referência da célula E1, ela não interpreta o conteúdo pois ira comparar com um valor igual
    3. a célula não aceita colocar >E1, pois somente aceita iniciar por =, qdo numero ou fórmula,  ou ' quando é texto.

    Pergunta: Como criar uma célula que possa ser modificável por uma variável e sirva de parâmetro para os ses do somases

    eu tentei copiar e colar aqui as planilhas e a formula, mas ficou ruim de entender. Se alguém souber como extrair só o que preciso e colocar aqui, agradeço.


    Rui Martins


    sábado, 20 de setembro de 2014 20:05

Respostas

  • Experimente:

    =SOMASES(ExtrAcumClass!$H$4:$H$503; ExtrAcumClass!$B$4:$B$503; $A7;ExtrAcumClass!$C$4:$C$503; ">"&E1;ExtrAcumClass!$C$4:$C$503;"<"&E2)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    terça-feira, 23 de setembro de 2014 22:46
    Moderador