none
Crystal reports Publicação de site DLL`S RRS feed

  • Pergunta

  •  

    olá pessoal, estou publicando um web site em vs2005 com c#.

    A aplicação executa normalmente na máquina de desenvolvimento, porém qdo esta é publicada no servidor ocorre um erro por falta das DLL's do Crystal. algumas dlls que precisavam eu coloquei no Bin do projeto e deu certo porem essas do crystal reports não deram...


    Alguém sabe como resolver este problema? Será necessário instalar o Crystal Reports no servidor?

    Segue o erro ao acessar a aplicação:


    Parser Error Message: Could not load file or assembly 'CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified.

     

    já me falaram que no servidor precisa estar instalado um tal de crystal analysis, mas não tem onde baixar isso

     

    me ajudem ai por favor

    agradeço...

    terça-feira, 14 de agosto de 2007 14:06

Todas as Respostas

  • Por que você não gera um pacote de instalação (setup project) e coloca o Crystal como dependência?

     

    terça-feira, 14 de agosto de 2007 14:46
  • Olá Giovanni! Vc conseguiu publicar seu site??? Estou com o mesmo problema que vc!
    segunda-feira, 17 de setembro de 2007 19:39
  • Lissandra, você colocou o crystal reports como pre-requisito do seu setup project?

     

    quinta-feira, 20 de setembro de 2007 12:25
  • Oi Leonardo! Consegui um artigo em inglês que falava sobre isso! Consegui ja! Muito Obrigada!Smile
    quinta-feira, 20 de setembro de 2007 13:43
  • Oi Lissandra...
    Tem como vc me passar este link? Eu estou a semanas procurando uma solução para este problema.. Já estudei tantas possibilidades e nenhum deu certo... Veja meus tópicos com o problema, se puder me ajudar com algum!!!

    MERGE MODULES CRYSTAL REPORTS XI
    http://social.msdn.microsoft.com/Forums/pt-BR/vsvbasicpt/thread/4c68db5c-ffea-4f2e-8d50-acc0a9ba319c

    PROBLEMA PARA PUBLICAR O PROJETO EM VS COM CRYSTAL REPORTS
    http://social.msdn.microsoft.com/Forums/pt-BR/vscsharppt/thread/e1a4abbe-8417-4d8e-89b2-2034872d44f7

    RUNTIME DO CRYSTAL REPORT NO VISUAL STUDIO 2008
    http://social.msdn.microsoft.com/Forums/pt-BR/vsteamsystemgeralpt/thread/60fde9d0-d365-4f01-aad7-e969d8a005ed

    Desde já muito agradecido!!!!

    moi
    terça-feira, 10 de fevereiro de 2009 12:31
  • Olá!

    Tive o mesmo problema mas com o vs2008 , sendo que resolvi instalando o arquivo "CRRedist2008_x86.msi" localizado no caminho :

    C:\Arquivos de programas\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\CrystalReports10_5

    Abraços,

    Anderson Salcedo

    quinta-feira, 7 de maio de 2009 13:16
  • Olá moi, vc conseguiu resolver seu problema?
    Vou ver se pego o artigo que falei, a questão é a seguinte, se no seu servidor não tiver crystal instalado na hora de gerar os relatórios dá erro. Então temos que instalar um pacote com dlls do crystal que "engana" o servidor, como se o crystal tivesse instalado lá e ai funciona.
    quinta-feira, 7 de maio de 2009 20:03
  • Muito obrigado Lissandra... Consegui sim...

    Abraço!
    mOi
    sexta-feira, 8 de maio de 2009 11:18
  • Muito obrigado Lissandra... Consegui sim...

    Abraço!
    mOi

    Como conseguiram resolver esse problema? Lissandra pode me ajudar?? Estou preicsando disso rs... Obrigado.
    quarta-feira, 26 de agosto de 2009 15:54