none
Excel retorna 0 em procv que deveria puxar outro valor RRS feed

  • Pergunta

  • Bom dia, amigos!

    Fui aconselhado por um moderador de outro fórum a postar aqui, na esperança de obter uma resposta..

    Alguém já viu isso? o Excel retorna o valor 0 onde deveria, puxado por um PROCV de outra tabela, retornar 1.

    https://drive.google.com/file/d/0B5G2mHnJSBPFYVAwQ1pVMVFEcFk/view?usp=sharing

    Na tabela RESUMO entramos com o valor de 1 para um produto

    Na tabela BOM 1 a qtd é identificada via procv na coluna C e multiplicada na coluna G o valor de C*F.

    Na tabela BOM 2, a qtd deveria ser identificada via procv da tabela BOM 1, mas não vem!

    Alguém poderia dar uma sugestão, ou ajudar a ver algo que estou deixando passar?

    Abraços e obrigado

    quarta-feira, 15 de fevereiro de 2017 11:58

Todas as Respostas

  • Ismael, bom dia.

    Na tabela BOM 1 tem registros onde o componente se repete, e a função PROCV retorna o primeiro valor encontrado.

    Você precisa criar uma referência única para cada registro para funcionar corretamente.

    Talvez o que você precise utilizar é a função SOMASE.

    Tente utilizar a fórmula abaixo na coluna C da tabela BOM 2 e veja se é isso que você procura.

    =SOMASE('BOM 1'!D:G;A2;'BOM 1'!G:G)


    Carlos Eduardo Ferreira



    quarta-feira, 15 de fevereiro de 2017 12:23
  • Apenas relatando,

    Tive o mesmo problema acima.

    O procv estava correto, a célula matriz estava correta e com valores distintos, porém o valor retornado era sempre e apenas 0.

    A única forma que consegui corrigir foi reaplicando o filtro em todas as tabelas.

    Um bug.

    quinta-feira, 24 de janeiro de 2019 12:17