none
Dúvida: String de Conexão com Entity Framework RRS feed

  • Pergunta

  • Gostaria de saber como posso passar a string de conexão com o PostgreSQL para o Entity Framework para incluir dados no banco, tem como?

    Desde já agradeço a atenção.


    Atenciosamente, Marcio Nogueira Cardoso Pinto.

    quarta-feira, 1 de janeiro de 2014 18:27

Respostas

  • O app.config não é do ASP.Net?

    Atenciosamente, Marcio Nogueira Cardoso Pinto.


    Não ... Mas, isso é só colocar no Web.config ... da na mesma!!! e tem exemplos relativos a isso no links!

    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcio_Nogueira quarta-feira, 1 de janeiro de 2014 19:32
    quarta-feira, 1 de janeiro de 2014 19:17
  • Gostaria de saber em qual ponto do app.config que devo colocar o código abaixo:

    <system.data>
      <DbProviderFactories>
        <add name="Npgsql Data Provider"
              invariant="Npgsql"
              description="Data Provider for PostgreSQL"
              type="Npgsql.NpgsqlFactory, Npgsql" />
      </DbProviderFactories>
    </system.data>


    Atenciosamente, Marcio Nogueira Cardoso Pinto.

      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <location path="WebForm1.aspx">
        <system.web>
          <authorization>
            <allow users="*"/>
          </authorization>
        </system.web>
      </location>  
      <system.web>
        <compilation debug="true" targetFramework="4.5"/>
        <httpRuntime/>
        <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
          <namespaces>
            <add namespace="System.Web.Optimization"/>
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt"/>
          </controls>
        </pages>
      </system.web>
      <system.web.extensions>
        <scripting>
          <webServices>
            <authenticationService enabled="true"/>
          </webServices>
        </scripting>
      </system.web.extensions>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="WebGrease" culture="neutral" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      <system.data>
        <DbProviderFactories>
          <add name="Npgsql Data Provider"
                invariant="Npgsql"
                description="Data Provider for PostgreSQL"
                type="Npgsql.NpgsqlFactory, Npgsql" />
        </DbProviderFactories>
      </system.data>
    </configuration>
    Tipo dependendo no final do seu webConfig abre um <system.data>


    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcio_Nogueira quinta-feira, 2 de janeiro de 2014 13:06
    quinta-feira, 2 de janeiro de 2014 13:02

Todas as Respostas

  • O app.config não é do ASP.Net?

    Atenciosamente, Marcio Nogueira Cardoso Pinto.


    quarta-feira, 1 de janeiro de 2014 19:14
  • O app.config não é do ASP.Net?

    Atenciosamente, Marcio Nogueira Cardoso Pinto.


    Não ... Mas, isso é só colocar no Web.config ... da na mesma!!! e tem exemplos relativos a isso no links!

    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcio_Nogueira quarta-feira, 1 de janeiro de 2014 19:32
    quarta-feira, 1 de janeiro de 2014 19:17
  • Gostaria de saber em qual ponto do app.config que devo colocar o código abaixo:

    <system.data>
      <DbProviderFactories>
        <add name="Npgsql Data Provider"
              invariant="Npgsql"
              description="Data Provider for PostgreSQL"
              type="Npgsql.NpgsqlFactory, Npgsql" />
      </DbProviderFactories>
    </system.data>


    Atenciosamente, Marcio Nogueira Cardoso Pinto.

    quinta-feira, 2 de janeiro de 2014 11:41
  • Gostaria de saber em qual ponto do app.config que devo colocar o código abaixo:

    <system.data>
      <DbProviderFactories>
        <add name="Npgsql Data Provider"
              invariant="Npgsql"
              description="Data Provider for PostgreSQL"
              type="Npgsql.NpgsqlFactory, Npgsql" />
      </DbProviderFactories>
    </system.data>


    Atenciosamente, Marcio Nogueira Cardoso Pinto.

      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <location path="WebForm1.aspx">
        <system.web>
          <authorization>
            <allow users="*"/>
          </authorization>
        </system.web>
      </location>  
      <system.web>
        <compilation debug="true" targetFramework="4.5"/>
        <httpRuntime/>
        <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
          <namespaces>
            <add namespace="System.Web.Optimization"/>
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt"/>
          </controls>
        </pages>
      </system.web>
      <system.web.extensions>
        <scripting>
          <webServices>
            <authenticationService enabled="true"/>
          </webServices>
        </scripting>
      </system.web.extensions>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="WebGrease" culture="neutral" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      <system.data>
        <DbProviderFactories>
          <add name="Npgsql Data Provider"
                invariant="Npgsql"
                description="Data Provider for PostgreSQL"
                type="Npgsql.NpgsqlFactory, Npgsql" />
        </DbProviderFactories>
      </system.data>
    </configuration>
    Tipo dependendo no final do seu webConfig abre um <system.data>


    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcio_Nogueira quinta-feira, 2 de janeiro de 2014 13:06
    quinta-feira, 2 de janeiro de 2014 13:02
  • Segue meu web.xml para verificar se há pontos para alterar:

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
      </configSections>
      <system.web>
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0"/>
      </system.web>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework"/>
        <providers>
          <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer"/>
        </providers>
      </entityFramework>
      <system.data>

        <DbProviderFactories>

          <add  name="Npgsql Data Provider"

                invariant="Npgsql"

                description="Data Provider for PostgreSQL"

                type="Npgsql.NpgsqlFactory, Npgsql" />

        </DbProviderFactories>

      </system.data>

      <connectionStrings>
        <add name="ChinookContext" connectionString= "Server=localhost;Port=5432;Database=curso;User Id=postgres;Password=Gx12J@27;" providerName="Npgsql" />
      </connectionStrings>
    </configuration>


    Atenciosamente, Marcio Nogueira Cardoso Pinto.

    terça-feira, 7 de janeiro de 2014 23:59