none
Problemas com texto justificado no Crystal Reports Basic do Visual Studio 2008 RRS feed

  • Pergunta

  • Bom dia a todos,

     

    Gostaria da ajuda de vocês quanto a um problema estranho que estou enfrentando com um relátório do Crystal Reports do Visual Studio 2008. Está ocorrendo o seguinte:

     

    Todas as vezes que eu insiro um campo de texto, configuro o alinhamento como justificado, e esse texto ficam com mais de uma linha, as letras ficam todas embaralhadas, ocupando o espaço de outra letra, por cima, além do texto não ficar justificado. Já tentei aumentar o tamanho do campo e marcar o item Can Grow, mas nenhum dos dois resolveu.

     

     Detalhe: Isso só acontece no crystal report viewer, na IDE de criação do relatório eu visualizo o texto normamente e justificado certinho.

     

    Outro detalhe: Isso só ocorre se eu justificar o texto, se alinhar à esquerda, direita ou centralizado isso não acontece.

     

    Último detalhe: Abri o relatório no Crystal Reports 2008, e o texto ficou normal, e justificado corretamente.

     

    Seria um bug do Crystal Reports do Visual Studio?? Alguém já passou por isso antes??

     

    Conto com a ajuda de vocês.

     

    Desde já, obrigado.

    quinta-feira, 16 de outubro de 2008 14:19

Respostas

  • Olá Henrique,

     

    Minha sugestão:

     

    Instalar o Service Pack (Crystal Reports) para Visual Studio .NET

     

     https://www.sdn.sap.com/irj/sdn/businessobjects-downloads

     

    Caso seja exibido uma tela para selecionar o certificação digital, clique no botão ok.

    Na tela de pesquisa faça o seguinte filtro:

     

    Software Product = Crystal Reports

    Product Version (optional)  = .NET

    e clique no botão search

     

    Instalar na máquina de desenvolvimento (Faça a instalação com o Visual Studio .NET fechado!)

     

    Nome do arquivo para download:

     

    .NET 2005

    Crystal Reports for .NET 2005 - SP 1

     

    .NET 2008

    Crystal Reports Basic 2008 - Service Pack 1

     

    [ ] 's

     

    Laércio.

    quinta-feira, 16 de outubro de 2008 14:24
    Moderador
  • Boa tarde,

     

    Laercio, instalei o SP1 do Crystal Reports para Visual Studio, notei as seguinte situação:

     

    Na IDE do VIsual Studio o campo texto do relatório, com alinhamentio justificado ficou normal, mas no viewer continuou do mesmo jeito. Fiz um tempo, mudei a fonte do campo para arial (estava utilizando a calibri) e o erro foi corrigido no viewer. Voltei para calibri e executei o aplicativo, com o programa em execução chamei o form com o viewer do relatório e o campo texto ficou perfeito!!

     

    Conclusão: O bug estava apenas no viewer na IDE do Visual Studio, e só para algumas fontes. Isso não será um problema, uma vez que não ocorrerá com o aplicativo rodando nas máquinas de meus clientes. Mas acredito que o SP1 do visual studio deva corrigir isso (já estou baixando).

     

    Obrigado mais uma vez pela ajuda.. e parabéns pela elaboração de mais um WebCast, pode ter certeza que vou baixar e assistir ele também!

     

    Um abraço.

    sexta-feira, 17 de outubro de 2008 16:21

Todas as Respostas

  • Olá Henrique,

     

    Minha sugestão:

     

    Instalar o Service Pack (Crystal Reports) para Visual Studio .NET

     

     https://www.sdn.sap.com/irj/sdn/businessobjects-downloads

     

    Caso seja exibido uma tela para selecionar o certificação digital, clique no botão ok.

    Na tela de pesquisa faça o seguinte filtro:

     

    Software Product = Crystal Reports

    Product Version (optional)  = .NET

    e clique no botão search

     

    Instalar na máquina de desenvolvimento (Faça a instalação com o Visual Studio .NET fechado!)

     

    Nome do arquivo para download:

     

    .NET 2005

    Crystal Reports for .NET 2005 - SP 1

     

    .NET 2008

    Crystal Reports Basic 2008 - Service Pack 1

     

    [ ] 's

     

    Laércio.

    quinta-feira, 16 de outubro de 2008 14:24
    Moderador
  • Obrigado pela atenção mais um vez Laercio,

     

    Vou fazer o download do Service Pack, porém só vou poder testar à noite. Depois posto o resultado.

     

    A propósito, seus WebCasts sobre os serviços de impressão ficaram ótimos.

     

    Um abraço.

     

    Até mais.

    quinta-feira, 16 de outubro de 2008 15:49
  • Henrique,

     

    Obrigado pelo feedback!

     

    Já terminei para a Comunidade MSDN o Terceiro Webcast sobre a construção de relatórios com Crystal Reports e ReportView em Windows Forms, com os seguintes bancos de dados (SQL Server 2008, SQL Compact 3.5, MS Access, MySQL e Oracle 10g Express).

     

    Assim que o vídeo for publicado no MSDN Media Center eu infomo aqui mesmo no fórum.

     

    [] 's

     

    Laércio.

     

    quinta-feira, 16 de outubro de 2008 22:34
    Moderador
  • Boa tarde,

     

    Laercio, instalei o SP1 do Crystal Reports para Visual Studio, notei as seguinte situação:

     

    Na IDE do VIsual Studio o campo texto do relatório, com alinhamentio justificado ficou normal, mas no viewer continuou do mesmo jeito. Fiz um tempo, mudei a fonte do campo para arial (estava utilizando a calibri) e o erro foi corrigido no viewer. Voltei para calibri e executei o aplicativo, com o programa em execução chamei o form com o viewer do relatório e o campo texto ficou perfeito!!

     

    Conclusão: O bug estava apenas no viewer na IDE do Visual Studio, e só para algumas fontes. Isso não será um problema, uma vez que não ocorrerá com o aplicativo rodando nas máquinas de meus clientes. Mas acredito que o SP1 do visual studio deva corrigir isso (já estou baixando).

     

    Obrigado mais uma vez pela ajuda.. e parabéns pela elaboração de mais um WebCast, pode ter certeza que vou baixar e assistir ele também!

     

    Um abraço.

    sexta-feira, 17 de outubro de 2008 16:21
  • Henrique,

     

    Eu que agradeço pelo pelo feedback! Precisando é só postar!

     

    [ ] 's

     

    Laércio.

     

    sexta-feira, 17 de outubro de 2008 16:50
    Moderador