locked
Formula por referência RRS feed

  • Pergunta

  • Olá! estou montando uma planilha, que faz calculo com base em outras, por referência. Atribuições funcionam normalmente :

    ='\\Servidor01\PROJETOS\PLANILHAS DE CONTROLE\Cliente\[Janeiro-2009.xls]Janeiro 2009'!$I$6

    mas um calculo, como : =SOMASE('\\Servidor01\PROJETOS\PLANILHAS DE CONTROLE\Cliente\[Janeiro-2009.xls]Janeiro 2009'!$AG$9:$AH$1000;E16;'\\Servidor01\PROJETOS\PLANILHAS DE CONTROLE\Cliente\[Janeiro-2009.xls]Janeiro 2009'!$AH$9:$AH$1000)

    so funciona quando a planilha está aberta!, quando eu a fecho, ele da erro (#valor)

    o google nao me ajudou muito... será que alguem poderia me dar uma luz?
    sexta-feira, 11 de setembro de 2009 14:54

Todas as Respostas

  • Realmente sempre vai acontecer isso

    A solução para resolver isso e colocar a aba Janeiro 2009 na planilha da formula e fazer uma macro para atualiza-la quando desejar.

    dai vc tira o vinculo

    Ok

    Wesley
    sábado, 12 de setembro de 2009 14:36
  • Saudações chará!

    acredito que no meu caso ficaria fora de mão... meu objetivo, era fazer algo como uma pesquisa... a pessoa digita uma data no campo, e o somase calcularia a produção naquela data... o problema é que tem uma quantia consideravel de planilhas....

    o fato seria que nao consigo fazer calculos em cima de vinculos certo? então, caso conseguisse colocar uma copia de cada planilha na planilha de pesquisa, pegaria as referencias das outras, e faria os calculos em cima das planilhas internas, certo?

    se for isso, tem como referenciar uma planilha inteira? sem ser campo a campo? nao entendo muito de macros...

    vlw!
    segunda-feira, 14 de setembro de 2009 10:09
  • vc pode referenciar a planilha assim


    ='[AVALIAÇAO FUNCIONAL INTERNA E EXTERNA.xls]1ª AVALIAÇÃO'!A1

    e depois copia para a´planilha inteira

    Wesley
    segunda-feira, 14 de setembro de 2009 13:57
  • A planilha ficou um pouco pesada, mas está tudo resolvido!

    muito grato pela ajuda!

    Att.
    segunda-feira, 14 de setembro de 2009 18:08