none
Como configurar o NLS do Oracle? RRS feed

  • Pergunta

  •  

    Tenho uma aplicação ASP.Net, utilizando OracleClient, e preciso garantir que as configurações de NLS da minha conexão oracle sejam sempre as mesmas.

     

    Como eu posso fazer esta alteração no objeto conexão?

    quarta-feira, 16 de janeiro de 2008 15:53

Respostas

  • Amigo existe varias formas

     

    1 - No seu servidor de banco de dados Oracle entre no registro e altere as configurações

    2 - Abra uma conexão com o banco de dados e faça um ALTER SESSION
    3 - Eu resolvi esse problema simplismente adicionando a seguinte linha no web.config

     

    <system.web>

    <globalization culture="pt-BR" uiCulture="pt-BR" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1" fileEncoding="iso-8859-1" />

     

    parametros do ALTER SESSION

     

    ALTER SESSION
       {SET { {SQL_TRACE | GLOBAL_NAMES | SKIP_UNUSABLE_INDEXES}={TRUE |
         FALSE}
            | NLS_LANGUAGE = language
            | NLS_TERRITORY = territory
            | NLS_DATE_FORMAT = 'fmt'
            | NLS_DATE_LANGUAGE = language
            | NLS_NUMERIC_CHARACTERS = 'text'
            | NLS_ISO_CURRENCY = territory
            | NLS_CURRENCY = 'text'
            | NLS_SORT = {sort | BINARY}
            | NLS_CALENDAR = 'text'
            | LABEL = {'text' | DBHIGH | DBLOW | OSLABEL}
            | MLS_LABEL_FORMAT = fmt
            | OPTIMIZER_GOAL = {ALL_ROWS | FIRST_ROWS | RULE | CHOOSE}
            | FLAGGER = {ENTRY | INTERMEDIATE | FULL | OFF}
            | SESSION_CACHED_CURSORS = integer
            | CLOSE_CACHED_OPEN_CURSORS = {TRUE | FALSE}
            | INSTANCE = integer
            | HASH_AREA_SIZE = integer
            | HASH_MULTILBLOCK_IO_COUNT = integer
            | REMOTE_DEPENDENCIES_MODE = {TIMESTAMP | SIGNATURE}
            | ISOLATION_LEVEL {SERIALIZABLE | READ COMMITTED}
            | CONSTRAINTSleep = {IMMEDIATE | DEFERRED | DEFAULT} } ...
       | CLOSE DATABASE LINK dblink
       | ADVISE {COMMIT | ROLLBACK | NOTHING}
       | {ENABLE | DISABLE} COMMIT IN PROCEDURE}
       | {ENABLE | DISABLE} PARALLEL DML

    Espero ter ajudado.

     

    quinta-feira, 17 de janeiro de 2008 12:05

Todas as Respostas

  • Amigo existe varias formas

     

    1 - No seu servidor de banco de dados Oracle entre no registro e altere as configurações

    2 - Abra uma conexão com o banco de dados e faça um ALTER SESSION
    3 - Eu resolvi esse problema simplismente adicionando a seguinte linha no web.config

     

    <system.web>

    <globalization culture="pt-BR" uiCulture="pt-BR" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1" fileEncoding="iso-8859-1" />

     

    parametros do ALTER SESSION

     

    ALTER SESSION
       {SET { {SQL_TRACE | GLOBAL_NAMES | SKIP_UNUSABLE_INDEXES}={TRUE |
         FALSE}
            | NLS_LANGUAGE = language
            | NLS_TERRITORY = territory
            | NLS_DATE_FORMAT = 'fmt'
            | NLS_DATE_LANGUAGE = language
            | NLS_NUMERIC_CHARACTERS = 'text'
            | NLS_ISO_CURRENCY = territory
            | NLS_CURRENCY = 'text'
            | NLS_SORT = {sort | BINARY}
            | NLS_CALENDAR = 'text'
            | LABEL = {'text' | DBHIGH | DBLOW | OSLABEL}
            | MLS_LABEL_FORMAT = fmt
            | OPTIMIZER_GOAL = {ALL_ROWS | FIRST_ROWS | RULE | CHOOSE}
            | FLAGGER = {ENTRY | INTERMEDIATE | FULL | OFF}
            | SESSION_CACHED_CURSORS = integer
            | CLOSE_CACHED_OPEN_CURSORS = {TRUE | FALSE}
            | INSTANCE = integer
            | HASH_AREA_SIZE = integer
            | HASH_MULTILBLOCK_IO_COUNT = integer
            | REMOTE_DEPENDENCIES_MODE = {TIMESTAMP | SIGNATURE}
            | ISOLATION_LEVEL {SERIALIZABLE | READ COMMITTED}
            | CONSTRAINTSleep = {IMMEDIATE | DEFERRED | DEFAULT} } ...
       | CLOSE DATABASE LINK dblink
       | ADVISE {COMMIT | ROLLBACK | NOTHING}
       | {ENABLE | DISABLE} COMMIT IN PROCEDURE}
       | {ENABLE | DISABLE} PARALLEL DML

    Espero ter ajudado.

     

    quinta-feira, 17 de janeiro de 2008 12:05
  •  

    Fiz o teste com o Alter Session e com a configuração do WebConfig e as duas funcionaram. Por enquanto vou deixar a solução via WebConfig e verificar se irá gerar algum efeito colateral.

     

    Obrigado.

    terça-feira, 22 de janeiro de 2008 18:02
  •  

    Até a próxima!
    quarta-feira, 23 de janeiro de 2008 15:32