none
Problema com parâmetros do tipo datetime RRS feed

  • Pergunta

  • Pessoal,

     

    Tenho um notebook com windows vista business original em inglês, estou usando o SQL Server Business Intelligence Development Studio para desenvolver relatórios, porém estou com um problema com os parâmetros do tipo datetime, quando clico no calendário ele me mostra o mesmo corretamente (no caso abre no mês atual) e se eu escolho a data 02/12/2008, quando eu clico em View Report ele muda a data para 12/02/2008 e se clico novamente no calendário o  mesmo já mostra o mês de fevereiro. Não consigo entender o que está acontecendo.

     

    Obs.: Nas minhas configurações regionais coloquei formato de data e moeda de acordo com o que usamos aqui no Brasil, no relatório e na table coloquei o idioma para Português (Brazil) 

     

     

    Grato,

     

    Duan Brito

    terça-feira, 2 de dezembro de 2008 12:50

Todas as Respostas

  • Vc pode tentar forçar o formato da data para o desejado, ex:

    =Format(Fields!DATA.Value, "dd/MM/yyyy")

     

    terça-feira, 2 de dezembro de 2008 13:09
  • Emanuel,

     

    Não entendi a resposta! Pode ser mais específico?

     

     

    Grato,

     

    Duan Brito

    terça-feira, 2 de dezembro de 2008 14:09
  • Duan,

     

    O que o Emanuel esta sugerindo, é que você realize a formatação dos dados, antes de passar os dados para o Reporting Services processar ou apresentar em tela.

    terça-feira, 2 de dezembro de 2008 16:15
  • Obrigado Junior.

     

    Duan, vc já verificou a configuração do browse? no IE, vc também pode configurar a linguagem, verifica se lá está fora do padrão que vc quer.

     

    Outra coisa, no BIDS, vc pode configurar a uma referência de linguagem, como "Same as Microsoft Windows", o caminho é o seguinte: tools\options\internationa settings\...

    terça-feira, 2 de dezembro de 2008 17:05
  • Junior,

     

    Onde eu faço essa conversão?

     

    Emanuel,

     

    No caso isso não me ajudou já que o micro é windows vista inglês.

     

     

    Grato,

     

    Duan Brito

     

    terça-feira, 2 de dezembro de 2008 18:02