locked
Dúvidas com fórmulas do excel 2003 RRS feed

  • Pergunta

  • Boa tarde, preciso de ajuda para fazer um procedimento no Excel 2003, eu acho que existe fórmulas pra isso só nao sei qual e nem como usa-las
    E o seguinte eu tenho uma coluna com valores reincidentes
    EX:
    Beth
    Jonh

    Paul
    Jason
    Michael

    Beth
    Jason
    Paul
    Beth

    E eu preciso de uma coluna que mostra os valores uma só vez sem contar com as cúlulas vazias e na frente a quantidade de vezes que o valor se repete na matriz, porém eu nao posso perder a matriz.
    Ficaria assim:
    Beth 3
    Jonh 1
    Paul 2
    Jason 2 
    Michael 1 
    Desde já agradeço a ajuda.
    sexta-feira, 22 de abril de 2011 17:28

Respostas

  • Olá Amigo.

    Faça da assim:

    Na Coluna A, será onde terá seus Dados Ex.: (Beth, Jonh, Paul e etc.)

    Na Coluna C, na célula C1, coloque a seguinte fórmula      =SE(A1="";"";SE(CONT.SE($A$1:A1;A1)=1;LIN();"")) , arraste a fórmula até a célula que você precisar

    Na Coluna D, na célula D1, coloque a seguinte fórmula       =SE(ÉERROS(INDIRETO("a"&MENOR($C:$C;LIN())));"";INDIRETO("a"&MENOR($C:$C;LIN()))), arraste a fórmula até a célula que você precisar

    Na Coluna E, na célula E1, coloque a seguinte fórmula        =SE(D1="";"";CONT.SE(A:A;D1)), arraste a fórmula até a célula que você precisar

     

    Depois se quiser ocultar a coluna "C" fique a vontade.

    Espero ter ajudado, abraço.

     

    Se ficou como queria, não esqueça de marcar como respondido.

     

    • Sugerido como Resposta Allvinho sexta-feira, 22 de abril de 2011 20:34
    • Marcado como Resposta vfsantos sexta-feira, 22 de abril de 2011 21:06
    sexta-feira, 22 de abril de 2011 20:33

Todas as Respostas

  • Olá Amigo.

    Faça da assim:

    Na Coluna A, será onde terá seus Dados Ex.: (Beth, Jonh, Paul e etc.)

    Na Coluna C, na célula C1, coloque a seguinte fórmula      =SE(A1="";"";SE(CONT.SE($A$1:A1;A1)=1;LIN();"")) , arraste a fórmula até a célula que você precisar

    Na Coluna D, na célula D1, coloque a seguinte fórmula       =SE(ÉERROS(INDIRETO("a"&MENOR($C:$C;LIN())));"";INDIRETO("a"&MENOR($C:$C;LIN()))), arraste a fórmula até a célula que você precisar

    Na Coluna E, na célula E1, coloque a seguinte fórmula        =SE(D1="";"";CONT.SE(A:A;D1)), arraste a fórmula até a célula que você precisar

     

    Depois se quiser ocultar a coluna "C" fique a vontade.

    Espero ter ajudado, abraço.

     

    Se ficou como queria, não esqueça de marcar como respondido.

     

    • Sugerido como Resposta Allvinho sexta-feira, 22 de abril de 2011 20:34
    • Marcado como Resposta vfsantos sexta-feira, 22 de abril de 2011 21:06
    sexta-feira, 22 de abril de 2011 20:33
  • Cara obrigado pela resposta em alguns caso funcionou perfeitamente só que quando a minha matriz muda as vezes ficam valores iguais na coluna D, se tiver alguma idéia agradeço.
    sexta-feira, 22 de abril de 2011 21:02
  • Não cara desculpa eu que colei errado ficou perfeito.

    Muito obrigado pela ajuda ja irei colocar como respondido.

    Vlw t+

    sexta-feira, 22 de abril de 2011 21:06